1

What does this mean for full disk encryption security if the encrypted partition never gets mounted? On the one hand, because the encrypted partition doesn’t get mounted, I wonder if that means my FDE is compromised and the PC’s drives are easier to access than they’re supposed to be (i.e. in effect, I don’t have true FDE). But on the other hand, my passphrase entry is still required before Ubuntu completes booting up. So, that makes me wonder if I’m still getting the full benefit of FDE in terms of the PC being extremely difficult to access without the passphrase.

Here's the strange story of what's happening:

I successfully set up FDE on Ubuntu 14 on a PC quite some time ago and it worked correctly. Then when I tried to upgrade to a newer Ubuntu distribution, things went wrong and I couldn’t get the PC to boot up at all. The Ubuntu grub appeared, but the PC did nothing after selecting Ubuntu. Also, I couldn’t do a successful reinstall.

I gave up on using the PC for some time, then I recently tried again to figure out how to boot it up. This time at the Ubuntu grub I played around with Advanced Options and was able to initiate a boot up.

Now comes the strange issue with the full disk encryption I initially set up. When I power on the PC, I don’t get the correct passphrase entry dialog box that I used to get when FDE was working normally. Instead, I get some miscellaneous scrolling white text on a black screen for several seconds, and then I get a prompt to “Enter Passphrase” at the end of a block of scrolled text.

Some of the text above the prompt to enter a passphrase:

running init-premount
mounting file root system
unlocking the disk (with name sda1_crypt)
then comes the "Enter passphrase" prompt

When I enter my passphrase (still the correct one from when I initially set up FDE), then the scrolling text resumes. In a few moments it boots up to the Ubuntu desktop. On the desktop I’m correctly presented with a logon option for the same account I set up initially, and an option to select a guest account.

After Ubuntu is booted, when I run Gparted, I can see the encrypted partition is not mounted. The only mounted partitions are 2 boot drives.

Here's what GParted looks like:

picture of Gparted

1

It sounds like your FDE is still working. Instead of the graphical interface for your encryption password prompt, you're being asked on the terminal. That's not an issue.

Gparted doesn't really support LUKS partitions. The red exclamation you see by the partition is associated with the following warning message. image.png

If you have FDE, you wouldn't be able to log into your system, much less run gparted unless your root partition was decrypted and mounted. If you're booted in, your in working order.

You can run gnome-disks and see LUKS partitions that are unlocked and mounted there. If you're not using LVM, you'll see something like this... image.png If you are using LVM, the LUKS partition will show as above, but the individual logical volumes in the physical volume (which is directly encrypted with LUKS) will show as block devices toward the bottom of the list in the left column where drives are listed. Clicking on these block devices will show where they are mounted. image.png

  • Thanks for your detailed reply. In my post above I added a screenshot of GParted just in case. So, it sounds like you're saying it's o.k. if I can see the unmounted crypt-luks partition in GParted? – Salem022 May 18 '17 at 1:55
  • Just to be clear - in the screenshot posted above note there's a red exclamation mark next to the crypt-luks partition - is that o.k.?. I don't know what that means, but I know partitions can also show the "key" or the "padlock" icon. – Salem022 May 18 '17 at 2:04
  • b_laoshi - sorry for all the comments. If my FDE was successful, shouldn't I be seeing a "padlock" on my crypt-luks partition in GParted and with FDE isn't my root partition supposed to be the crypt-luks partition? Based on the GParted screenshot, does this mean my mounted, root partition is actually an unlocked, unencrypted partition? If so, am I correct this means my FDE isn't working the way it's supposed to? In other words, all of my activity is going on an unencrypted partition? – Salem022 May 18 '17 at 2:31
  • The red exclamation mark is totally normal in gparted for LUKS partitions. Gparted doesn't support LUKS. I'll update my answer with another screenshot. – b_laoshi May 18 '17 at 2:39
  • (again sorry- our comments crossed - I didn't see you last comment before adding this new comment). I'll wait for your update, but come to think of it, I could swear I used to see the padlock in GParted next to my crypt-luks partition. – Salem022 May 18 '17 at 2:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.