1

I have successfully installed Android Studio on my unity install on my Chromebook. The problem is the emulator says the /dev/kvm is not found. Running sudo kvm-ok gives:

INFO: /dev/kvm does not exist HINT: sudo modprobe kvm_intel INFO: Your CPU supports KVM extensions KVM acceleration can be used

I have tried reinstalling various packages but no matter what I do I can't get kmv to work. Running sudo modprobe kvm (or any amd or intel derivative) results in kvm nor found.

I have installed libvirtd and added me as a user but when I run any virsh command it says:

error: failed to connect to the hypervisor error: no valid connection error: Failed to connect socket to '/var/run/libvirt/libvirt-sock': No such file or directory

I am clutching at straws installing whatever I can find but to no avail.

Any help appreciated

  • A week of trying and still no further forward. Can no one on here offer any help? – faarn May 25 '17 at 8:45
1

As far as I have read, the Chrome OS kernel has been compiled to deliberately not support the virtualisation capabilities of the CPU. I take it you are running Crouton? If so, this sums it up best - https://github.com/dnschneid/crouton/issues/189. You would have to recompile your kernel with the virtualisation switch turned on.

Do you know you can run Android Studio in a window in Chrome OS via Crouton using XIWI (command from shell:- sudo enter-chroot xiwi studio)? Then you can connect to the Chromebook's Android OS via ADB and run your applications natively with no need for any virtualisation. Obviously you lose the ability to see what your app looks like on other Android versions and devices but at least you get to run your app. It's probably the best you can do on a Chromebook at the moment and it's a lot easier than it sounds. Just remember to generate the command line launcher from within Android Studio first (Tools -> Create Command-line Launcher...). Full details here:- https://android.jlelse.eu/developing-android-apps-right-on-your-chromebook-f3a00cb78e0e

FWIW, AIDE recently added Chromebook support for their Android app, including Chromebook trackpad support and window resizing. Because it's all running in Android, it's quicker than Android Studio on a Chromebook. It's not as powerful as Android Studio but it might be worth a look...

| improve this answer | |
  • 1
    Oops, I just realised you posted this May last year, not May this year. You're probably all sorted one way or another now. Anyway, I guess it's worth leaving this here for anyone else with the same problem. – EpochGrinder Jul 1 '18 at 12:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.