1

Problem description:

My intention is to enable PHP5 on Xenial 16.04 for an Apache2-related project

I have compiled PHP v5.6 from official source and am currently trying to install package libapache2-mod-php5.6 using https://launchpad.net/ubuntu/xenial/amd64/libapache2-mod-php5.6/5.6.18+dfsg-4ubuntu1

After attempting to resolve dependencies, I end up with php5.6-common from https://launchpad.net/ubuntu/xenial/amd64/php5.6-common/5.6.18+dfsg-4ubuntu1 depending on php-common, however, after installing said php-common via apt, I keep getting following message:

    The following packages have unmet dependencies:
      php5.6-common : Depends: php-common (>= 18~) but it is not going to be installed
    E: Unable to correct problems, you have held broken packages.

Do I also need some outdated version of php-common?

Should I also build libapache2-mod-php5.6 from source (and if so, are there any code packages suited to compile properly on Xenial)?

NOTE: I am NOT supposed to use Ondrej's ppa due to company policy

1

This is similar to your problem. So as written there, you could give

sudo apt-get -f install

a try which is supposed to search and install unmet dependencies.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.