2

On my Laptop (ASUSPRO P2520LA with Ubuntu 16.04) when I play any sound I get random audio glichtes (some kind of stuttering as if half a second or so was cut out) every 2-5 minutes.

  • These glitches seem to occur randomly and I don't have any way to reproduce them. Sometimes the audio even works half an hour bevore a glitch occurs

  • It's just a small "stuttering" but when watching longer video sor listening to music it is quite annoying

  • The glitches even occur when playing the sound with HDMI on a TV, with an external sound card or with headphones

  • I have tried multiple suggestions I found online to fix it (see below) but none of them worked for me.

Does anyone have and idea that I could try? Thanks a lot for your help!

Some info on my system:

>lspci -v | grep -A7 -i "audio"
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller (rev 09)
    Subsystem: ASUSTeK Computer Inc. Broadwell-U Audio Controller
    Flags: bus master, fast devsel, latency 0, IRQ 52
    Memory at b221c000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

00:04.0 Signal processing controller: Intel Corporation Broadwell-U Camarillo Device (rev 09)
--
00:1b.0 Audio device: Intel Corporation Wildcat Point-LP High Definition Audio Controller (rev 03)
    Subsystem: ASUSTeK Computer Inc. Wildcat Point-LP High Definition Audio Controller
    Flags: bus master, fast devsel, latency 32, IRQ 50
    Memory at b2218000 (64-bit, non-prefetchable) [size=16K]
    Capabilities: <access denied>
    Kernel driver in use: snd_hda_intel
    Kernel modules: snd_hda_intel

00:1c.0 PCI bridge: Intel Corporation Wildcat Point-LP PCI Express Root Port #1 (rev e3) (prog-if 00 [Normal decode])

Here is what I have tried so far:

sudo gedit /etc/modprobe.d/alsa-base.conf
add the line: 
snd-hda-intel model=auto
==============================================================

killall pulseaudio; rm -r ~/.config/pulse/* ; rm -r ~/.pulse*
==============================================================
sudo apt-get update;sudo apt-get dist-upgrade; sudo apt-get install pavucontrol linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-`uname -r` libasound2; sudo apt-get -y --reinstall install linux-sound-base alsa-base alsa-utils lightdm ubuntu-desktop  linux-image-`uname -r` libasound2; killall pulseaudio; rm -r ~/.pulse*; ubuntu-support-status; sudo usermod -aG `cat /etc/group | grep -e '^pulse:' -e '^audio:' -e '^pulse-access:' -e '^pulse-rt:' -e '^video:' | awk -F: '{print $1}' | tr '\n' ',' | sed 's:,$::g'` `whoami`
==============================================================
sudo gedit /etc/pulse/default.pa
find the line: load-module module-udev-detect
change it to:  load-module module-udev-detect tsched=0
pulseaudio -k
==============================================================
sudo -H gedit /etc/pulse/daemon.conf
find the line: ; resample-method = 
change it to:  resample-method = src-sinc-best-quality
(ohne semikolon)
=============================================================(kein erfolg)
sudo gedit /etc/modprobe.d/alsa-base.conf
add the line: options snd-hda-intel vid=8086 pid=8ca0 snoop=0
===================================================================================
from https://askubuntu.com/questions/160882/popping-noise-from-laptop-speakers
---------------
sudo nano /usr/lib/pm-utils/power.d/intel-audio-powersave
Find the line:

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

Comment it out using "#". Underneath add the line:

INTEL_AUDIO_POWERSAVE=false

Save and exit, then restart.

sudo sh -c 'echo 0 > /sys/module/snd_hda_intel/parameters/power_save'
sudo sh -c 'echo N > /sys/module/snd_hda_intel/parameters/power_save_controller'

sudo chmod 550 /sys/module/snd_hda_intel/parameters/power_save
sudo chmod 550 /sys/module/snd_hda_intel/parameters/power_save_controller


===================================================================================
from https://askubuntu.com/questions/160882/popping-noise-from-laptop-speakers
---------------
alsamixer -c0
Press F6 and select your sound card (in my case HDA Intel PCH).
Go towards the right and disable Auto-Mute M.
===============================================0
gksudo gedit /etc/modprobe.d/alsa-base.conf
options snd-hda-intel model=auto vid=8086 pid=8ca0 snoop=0 power_save=0 power_save_controller=N

migrated from stackoverflow.com May 16 '17 at 22:06

This question came from our site for professional and enthusiast programmers.

  • This should go on the Ubuntu SE site because it's not a programming question. – EJoshuaS May 16 '17 at 18:00
  • Sorry, you are right. Can this post be moved there? Or should I delete it here and repost it on Ubuntu SE? – Raphael May 16 '17 at 20:20
  • In cases like that you can flag for moderator attention asking them to migrate it. – EJoshuaS May 16 '17 at 20:24
  • Hey @Raphael, me too. Did you find a solution? – Michael Cole Oct 16 '17 at 19:23
  • What wireless network adapter do you use? Check it with lshw -C network. Because there is a bug in kernel which causes audio stutter if your wifi enabled and you are not connected to any wifi network. – GoodGuyNick Aug 16 '18 at 7:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.