0

This is a question that has occasionally been asked in the past. I have tried the various fixes proposed by others but haven't had any success. I can connect to wifi when not booting Ubuntu. Here's some background information:

  • I have tried various fixes from similar threads such as resetting the network manager and unblocking wifi.
  • As alluded to, this is a dual install. I can connect to wifi without issue when booting Windows.
  • The Software & Updates section of Settings does not display any needed proprietary drivers.
  • The ASUS motherboard I have comes with a USB for drivers. It contains a readme for Linux users saying to upgrade to the latest Linux Kernel (though this readme was probably written years ago). Could the branch of Linux Kernels for 14.04 be out-of-date for this motherboard?

Let me know if there's any command lines I should run and post results for. I haven't used Ubuntu or Linux before so I don't know what diagnostics could be useful.

Thanks.

Updated Information:

The output for sudo lshw -C network is

*-network
    description: Ethernet interface
    product: Ethernet Connection (2) I218-V
    vendor: Intel corporation
    physical id: 19
    bus info: [ci@0000:00:19.0
    logical name: eth1
    version: 0.5
    serial: 2c:56:dc:39:18:6d
    capacity: 1Gbit/s
    width: 32 bits
    clock: 33Mhz
    capabilites: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.1-4 latency=0 link=no multicast=yes port=twisted pair
    resources: irq:63 memory:fb100000-fb11ffff memory:fb136fff ioport:f000(size=32)
*-network
    description: Ethernet interface
    product: I211 Gigabit Network Connection
    vendor: Intel Coporation
    phsyical id: 0
    bus info: pci@0000:0b:00.0
    logical name:eth0
    version: 0.3
    serial: 2c:56:dc:39:db:bd
    capacity: 1Gbit/s
    width: 32 bits
    clock: 33MHz
    capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
    configuration: autonegotation=on broadcast=yes driver=igb driverversion=5.3.0-k firmware=0. 6-1 latency=0link=no multicast=yes port=twisted pair
    resources: irq:18 memory:fb600000-fb61ffffioport:c000(size=32) memory:fb620000-fb623fff
*-network
    description: Network controller
    product: BCM4360 802.11ac Wireless Network Adapter
    vendor: Broadcom Coporation
    physical id: 0
    bus info: pci@0000:0d:00.0
    version: 03
    width: 64 bits
    clock 33MHz
    capabilities: pm msi pciexpress bus_master cap_list
    configuration: driver=bcma-pci-bridge latency=0
    resources: irq:18 memoryfb400000-fb407fff memory:fb200000-fb3fffff

and for lspci -nnk | grep net -A2

00:19.0 Ethernet controller [0200]: Intel Coporation Ethernet Connection (2) I218-V [8086:15a1] (rev 05)
        Subsystem: ASUSTeK Computer Inc. Device [1043:85c4]
        Kernel driver in use: e1000e

0b:00.0 Ethernet controller [0200]: Intel Coporation I211 Gigabit Network Connection [8086:1539] (rev 03)
        Subsystem: ASUSTeK Computer Inc. Device [1043:85f0]
        Kernel driver in use: igb

Second Error Message:

Here is the second error message upon installing the two packages:

...
ERROR (dkms apport): kernel package linux-headers-4.4.0-31-generic is not supported
Error! Bad return status for module build on kernel: 4.4.0-31-generic (x86_64)
Consult: /var/lib/dkms/bcmwl/6.30..../build/make.log for more information.
modprobe: FATAL: Module wl not found.
  • Please review this post to help provide information that will be needed to help you – Charles Green May 16 '17 at 19:54
  • Thanks, but I'm a bit confused. The post you linked says if you can't connect to the Internet with a wired or wireless connection then you have to transfer files to a system with Internet. What files do I need to transfer? Can I still do this if my only system with Internet connection uses a Windows operating system? – Blackmill May 16 '17 at 20:06
  • There is a script (command terminal stuff) that can be run, which will provide a big clock of text describing your wireless system. It just under the bit that says "Ctrl+Alt_t". You may need to copy this onto a USB drive, boot Ubuntu and run the script - then copy the text from the terminal window, paste it into a text file, and get the results back onto this question, by editing your question and posting the text in. – Charles Green May 16 '17 at 20:57
  • @CharlesGreen That's what I figured, but when I ran the script, I got a resolving github.com failed: Name or service not known error. I've checked I put in the correct address several times and that's not the issue. I've read about Broadcom cards being problematic but I don't think I have one. – Blackmill May 16 '17 at 21:16
  • My bad - I forgot that requires an internet configuration. sudo lshw -C network will show network infterfaces known by your computer - please check to see if it sees your wireless interface. You might also run lspci -nnk | grep net -A2 if it's a pci based network adaptor, or lsusb if it's a USB device. – Charles Green May 16 '17 at 22:12
0

You will need to download two packages from the internet, transfer them to USB, and take them to your computer. The packages are

Broadcom wireless driver

DKMS

Other than these newer links for Ubuntu trusty (14.04) you should follow the instructions as in this answer - use arch to determine which architecture you need, download the .deb files, copy them into a directory in your computer.

Then use sudo dpkg -i *.deb from that some directory to install the two packages, followed by sudo modprobe wl. This should load the drivers required for your wireless adaptor.

  • I downloaded those two deb files and installed them. Unfortunately, it gives me a similar error message to that under edit2 in the answer you linked. I've included the error message in the original post and suspect the problem is the unsupported linux headers. From reading this it seems I just have to install the correct linux-headers. Apparently they can be very buggy though and I'm unsure which version is stable or needed. – Blackmill May 17 '17 at 8:14
  • It would appear that you need version 4.4.0 of the headers - you don't have an ethernet cable to connect your computer to the router? – Charles Green May 17 '17 at 13:06
  • I don't. I could probably get one, though, if that's the only way to get the headers. Do I just enter some command line, with internet connection, and the right headers will automatically be downloaded? – Blackmill May 17 '17 at 17:00
  • I installed the deb file containing the linux headers 4.4.0-31. The terminal even said unpacking linux-headers-generic or something similar and no error messages came up. And yet my system doesn't seem to register the linux headers as installed if I query for the current version. – Blackmill May 17 '17 at 19:14
  • You can check installation of the headers with apt-cache policy linux-headers-generic, which will tell you the version you have installed. In a terminal window, try sudo dpkg --configure -a - if a package was half installed, this should correct the situation. – Charles Green May 18 '17 at 0:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.