17

Can anyone tell me how to get the spellchecker working in Libre Office 5.2? I would have thought that this was a basic installation!

1
20

I tried Brayden's answer but I also had to go to Tools > Language > For all Text > English (USA) to get it to work.

enter image description here

1
  • I additionally had to follow kpnuts1963's answer to change user interface language from "Default - English (USA)" to "English (USA)". After LibreOffice restart, I then had underlining.
    – Rasmus
    May 30 at 9:34
18

I had to install a dictionary to fix it. apt-get install myspell-en-gb worked here in the UK.

If you are using a more recent version of Ubuntu then you now need the hunspell-en-gb package, so

apt install hunspell-en-gb
2
  • 2
    If you're going to downvote a solution as unambiguous as this, it would be helpful to post a comment saying why. After fiddling with all the other solutions on this question and from other online sources, this simple step was what finally solved the problem for me. On another note, this really ought to be a dependency package for libreoffice. Such a basic feature shouldn't inexplicable fail to work on a fresh install! Mar 10 '18 at 18:10
  • 2
    This worked for me but I think the myspell package has been removed as of 18.10 so I used apt install hunspell-en-gb
    – finsbury
    Jan 29 '19 at 14:46
14

I am on Ubuntu 18.04 using LibreOffice Writer Version: 6.0.3.2, I encountered the same problem, and to solve it I had to install the language package. I used sudo apt-get install hunspell-en-gb to install the English language pack, as sudo apt-get install myspell-en-gb, did not work for me. I hope this helps.

7

In Ubuntu 16.04,none of the above seemed to help me so I tried something different and it worked. Go to: System settings > Personal - language support This opens a system checker that flags missing dictionaries etc. It then offered me an option of fixing hunspell partial installation, and installing what it needed. Simple in the end.

1
  • Worked in Ubuntu 21.04 too. Open "Language Support".
    – Flimm
    Jul 28 at 11:37
2

First make sure the functionality of spell checker is enable. You can simply use Shift+F7 to turn it on or off. Or from tools menu > Automatic spell checking.

Then press F7 to open spelling and grammar window.

enter image description here

Make sure "Text language" is selected correctly; use available options to correct the spells.

Other languages dictionaries are available from here.

You can also click on "options" to make sure if necessary options are enabled:

enter image description here

1

HI If you leave user interface as " Default - English(USA)" and or locale setting as " Default English (UK) " spell check wont work. Choose from the drop down menus so it just says " English (USA) " and " English(UK)" and not the "default" bit then restart LIbreoffice and checker will work.

1
  • Thank you! This was the final that did it for me!
    – Rasmus
    May 30 at 9:32
0

You have to set you default language to English US: Open Libre Office > Options > Tools > Language Settings and set you language to English (USA).

App launcher:

Language settings:

0

I had exact same issue and the default settings did not work for me. This worked for me. Even hunspell or myspell, as suggested by Aaron and some others, didn't work.

However adding this extension to Libre Office worked for me: https://extensions.libreoffice.org/extensions/english-dictionaries/ First download it to your computer and then in Lbre Office to go to Tools > Extension Manager > Add > {upload extension file}. Restart application.

Not the answer you're looking for? Browse other questions tagged or ask your own question.