2

Been trying to install libapache2-svn for hours using the command sudo apt-get install libapache2-svn but no luck it gives me the error (unable to locate package libapache2-svn) over and over again.
I've tried updating the ubuntu server many times but still gives the same error.

Thanks in advance.

P.S if libapache2-svn repository is not available for 17.04 is there a way to install it then for 17.04?

  • Please enable trusty-updates and trusty-updates in system settings --> software & updates – George Udosen May 16 '17 at 16:00
  • 1
    I'm a bit confused - your title indicates version 17.04, and the tag is version 14.04. Please update your question with the output of uname -r – Charles Green May 16 '17 at 16:06
  • I agree with @CharlesGreen please which is it, as I can see it in Ubuntu Trusty – George Udosen May 16 '17 at 16:09
  • my bad. Removed the 14.04 in the tags. Can you confirm if libapache2-svn is included in 17.04? – Supremo May 17 '17 at 1:32
6

I don't know about 17.04, but in 18.04, the package is called libapache2-mod-svn

1

Please check and make sure these trusty-updates and trusty-updates are enabled in your system settings like the image below:

enter image description here

See my out when I search for it:

george@george-VirtualBox:~$ apt search libapache2-svn
Sorting... Done
Full Text Search... Done
libapache2-svn/trusty-updates,trusty-security 1.8.8-1ubuntu3.2 all
  Apache Subversion server modules for Apache httpd (dummy package)
  • 1
    I think that the tag indicating version 14.04 is incorrect, and queried the op on that. libapache2-svn is not included in the 17.04 repositories. – Charles Green May 16 '17 at 16:09
  • Yes just saw your query. – George Udosen May 16 '17 at 16:09
0

Try editing the /etc/apt/sources.list file for the "http://" with "ftp://" and then run sudo apt-get update and then sudo apt-cache search subversion if results are found then proceed installation with sudo apt-get install subversion or else run sudo apt-cache search libapache2-svn then if results are found here then do a sudo apt-cache install libapache2-svn.

  • Still doesnt work. I tried running sudo apt-cache search libapache2-svn but no results found but i still tried running sudo apt-cache install libapache2-svn but it returned an error "Invalid operation install", I then tried sudo apt-get install libapache2-svn but still returns an error "Unable to locate package libapache2-svn" – Supremo May 16 '17 at 15:55
  • @Supremo try the source list generator repogen.simplylinux.ch and then try update and then install, proceed with caution although. If there is something you do not know what you are doing simply stop and ask the same question on serverFault or refer to serverfault.com/questions/209055/… – Shakti Phartiyal May 16 '17 at 15:59
0

libapache2-svn is just a dummy package for installing Apache Subversion server modules for Apache httpd (libapache2-mod-svn). libapache2-svn is not available in the 17.04 repositories, but you don't need to install this dummy package, install libapache2-mod-svn without installing the dummy package instead.

In all currently supported versions of Ubuntu open the terminal and type:

sudo apt install libapache2-mod-svn
0

Make sure you have enabled Ubuntu repositories:

sudo add-apt-repository main  
sudo add-apt-repository universe 
sudo add-apt-repository restricted  
sudo add-apt-repository multiverse  

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.