so here is my problem: On my Lenovo t430i I replaced CD-ROM drive with 128 SSD OCZ-SOLID3 and installed latest Linux Mint 18.1 64-bit on it.

Everything was working flawless but I wanted to make it dual boot and installed Win7 64-bit on primary 320GB drive.

Windows is booting all right but I've lost access to Linux partition. To solve this problem I've used boot-repair CD and booted it from USB key.

So far so good. I attempted to repair and chosen NO-RAID option, and then Recommended Repair. Was following the wizard and got to the "Please open a terminal and type [...]" which I did. But last command:

sudo chroot "/mnt/boot-sav/mapper/mint--vg-root" apt-get install -y --force-yes grub-efi-amd64-signed shim-signed linux-signed-generic

gave me following error:

    The following packages have unmet dependencies:
 linux-signed-generic : Depends: linux-headers-generic (= but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Here I pasted entire terminal output: https://pastebin.com/f46vTs4E

And here: http://paste.ubuntu.com/24582235/ boot-info output

I've tried everything I coud find on Google but nothing worked so far. I don't want to lose my Mint partition because I have some important data on it and it would be a real pain to retrive it manually. If there is something unclear in my description, please let me know and I'll try to provide more info.

Thank you


Your Boot Repair output indicates that you booted the computer with Secure Boot disabled. Thus, there's no need to install the signed versions of the Linux kernel, which is what the linux-signed-generic package would install, unless of course you intend to enable Secure Boot. If so, you should be able to add linux-headers-generic to work around the problem. That's referenced on line 55 of your bash session. (Knowing to interpret and handle such messages is an important skill.)

Thus, I suggest you try again, but this time either omit the linux-signed-generic package from the apt-get install command or add linux-headers-generic. If you try the latter, be aware that you might conceivably end up with some other broken dependency, in which case you should read the output for a specified dependent package and add it to the list.

An alternative approach is to use my rEFInd boot manager:

  1. Download the USB flash drive or CD-R version of rEFInd. Download links for both appear on the rEFInd downloads page.
  2. Prepare a boot medium from the file you download.
  3. Boot it as if it were an OS installer. The rEFInd menu should appear.
  4. Boot to Ubuntu.
  5. In Ubuntu, install (or re-install) a boot loader. Two options are likely to be easy:
    • Typing sudo grub-install followed by update-grub should re-install GRUB; however, it sounds as if the GRUB package may not be installed already. If so, you'll need to first do a sudo apt-get install grub-efi. This might create the sort of dependency issues you're reporting, though.
    • You can install the Debian package or PPA version of rEFInd to install it to your hard disk. It will then take over as your boot manager; you'll no longer need GRUB.
  • 1
    Thank you, you helped me a lot. I've just done what you suggested - omitted linux-signed-generic, don't care that much about Secure Boot. I was able to login into my Linux Mint partition. – S1awek May 16 '17 at 10:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.