0

I'm trying to use a live USB of Ubuntu Gnome 17.04 on my 2013 Mac Pro (trash can model). But I'm getting stuck in a loop during the text output during the booting process.

I have rEFInd set up (since I'm already running 16.04), and I select the USB drive to boot into Grub. I select boot from USB. I see the logo animate for a bit, which I'm guessing is gnome or gdm related. Then I get the following output on the screen in TTY (with times ommitted):

bmca: Unsupported SPROM revision: 11
bmca: bus0: No SPROM available
sd 1:0:0:0: [sdb] No Caching mode page found
sd 1:0:0:0: [sdb] Assuming drive cache: write through
sd 2:0:0:0: [sdc] No Caching mode page found
sd 2:0:0:0: [sdc] Assuming drive cache: write through

I can see the output disappear and reappear frequently, like it's getting stuck in a loop. I've searched these error messages, and they suggest disabling WiFi since it could be a driver issue. But I'm using rEFInd, which I don't think has that option.

Any ideas?

1
  • When you boot an Ubuntu installation USB drive from rEFInd, chances are it's launching GRUB, so you can do anything you'd do in GRUB. If you launch a kernel directly, you can hit F2, Insert, or Tab twice to get to a simple line editor that you use to edit kernel options. – Rod Smith May 15 '17 at 22:56
1

I've solved the initial problem: If you boot using USB, edit the GRUB entry for booting to live. Under the linux command, add nomodeswitch as a parameter. There seems to be an issue with the video drivers on this computer.

However once it's installed, I still need the nomodeswitch parameter or else Ubuntu won't boot. Currently trying to figure this out.

2
  • I've never used it (I hate GRUB), but GRUB Customizer is said to be helpful for editing GRUB's options. This really just helps you edit files in /etc/grub.d and /etc/default/grub, so you could edit the appropriate file directly -- I think it would be the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub, but I'm not positive of that. You'd then need to run sudo update-grub to activate your changes. You can do the same thing with most boot loaders by editing their configuration files, but details vary depending on the boot loader. – Rod Smith May 19 '17 at 17:48
  • Oh, I missed in the original question that you're using rEFInd. If you launch your kernels directly from rEFInd, you can edit /boot/refind_linux.conf to add the nomodeswitch option. If that file isn't present, run mkrlconf from Ubuntu. (This script comes with rEFInd, but might not be installed in Ubuntu if you installed rEFInd from OS X.) – Rod Smith May 19 '17 at 17:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.