1

This is the how each google search result looks

The past two days whenever I do a google search this is the result, certain parts of the result are just boxes.This is not only the problem in firefox the same is the status in google chrome.I think it is some sort of local setting that is doing this. I removed ~/.cache/fontconfig/ and then ran sudo fc-cache -fr and rebooted ....still no change.I had been changing the font of GRUB( the boot loader) ..... I think it might be related as this happened around the same time.Hope you guys can help me with this.I have added the output font below. మీకు కావలసింది ఇదేనా.

  • oh sorry you already had one. yeah I'm perplexed but indeed the grub edit could be the culprit. asfor undoing your changes is the issue that you don't have the originals anymore? you can get parts or whole examples off the web. – tatsu May 15 '17 at 12:14
  • Hey, thanks ...... I am kinda new to ubuntu itself.... what do you mean by examples, what should I search for and how should I restore/undo it?....... if a similar topic has been covered in an other thread can you direct me there? – A Nerd Has No Name May 15 '17 at 12:19
  • no resemblent threa dthat I know of. – tatsu May 15 '17 at 12:42
  • well no there's no exact thread like this that I know of but messing up system/deleting files is a relatively commont issue and there are two easy fixes : if you've set up back in time use that if not reinstall system here's my guide : askubuntu.com/a/914480/307184 – tatsu May 15 '17 at 12:47
1

I have a weird suggestion for you that may work by reinstalling your language files:

Go to "language support" and switch to a language that you can still navigate through... (Thank goodness for icons, right?) In my case, I chose Spanish. Set it to be your primary language. Then DELETE the language pack in which you are having issues. i.e. the one that is showing the problem.

Reboot. Navigate back to the "language support", reinstall the language packs for your chosen primary language. I assume one of the English variants... and it SHOULD reinstall the main fonts. Thereby fixing your fontcache problem.

I just tried it with Japanese on my test system. And, it apparently re-downloads all the fonts along with the language packs.So, this might just be what you are looking for.

It may seem reckless. But, if your only other option is considering a clean install anyway. What harm could it possibly do?

  • I'm glad you got it worked out. That was a strange one. I didn't know that google language settings had such global effect... But, please do not "accept" an answer unless it actually solved the problem for you. Others may make the mistake of thinking the answer you accepted was "correct"... when actually it may not be correct at all. The solution that YOU found should be clearly written as the answer... And, you could even "accept" your own answer if you want to. – Orian May 15 '17 at 13:41
  • well thanks man....yours also seemed to be around the same solution....so I thought yours would also work – A Nerd Has No Name May 15 '17 at 14:29
1

I am so sorry that I wasted all of your time ...... I changed everything from grub to the font congfig file.... Nothing worked. And finally, guess what I went to google.com the I had changed the language to some weird language and I can recall when it happened but that is what happened to me.

See.......

.... I must have selected any of this language.......funny story of why it was spread to two different browsers(firefox and chrome) must be because I was signed into the same google account.I did not even thing of using incognito.... if I did this would have been obvious. Thanks for the help guys

  • If you think an answer is useful, you could certainly "Mark it as Useful". But, in this case, it wasn't the actual solution for your problem. – Orian May 15 '17 at 14:33
1

1st type of solution :

A good universal fix is always to reinstall the system depending on how you partition.

Getting back 100% of your workspace and functionality this way can sometimes be incredibly fast.

2nd type of solution :

(may not work)

try boot repair could work, who knows? : https://doc.ubuntu-fr.org/boot-repair

do this :

install oot repair

then run it and do :

boot repair running

3rd type of solution :

attempt to undo the changes haphazardly (low chance of success)

Ok so I don't know if the following is a good practice or it will work but I have here the contents of my fontconfig folder : https://www.dropbox.com/pri/get/Public/fontconfig.zip?_subject_uid=22720750&w=AAAdWvbuTOY4qgOgT1fFUvQzz5_hwWW3YYRqfzoZmvpCGA

As for grub this : https://crux.nu/ports/opt/3.0/grub2/grub.cfg.sample

and this : https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/3/html/Reference_Guide/s1-grub-configfile.html

...is as good as it gets.

You HAVE to fid the drive IDS and enter them in yourself.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.