0

When using Ubuntu I can only get sound through the subwoofer underneath the laptop and not from the left and right speakers located between the body and the screen (when open). I've tried all remedies and from what I can tell it is a bug with the audio software.

Making any kind of change results in no audio at all.

If anyone knows any fix for this that would be appreciated but as I have already spent hours searching I am sure it is a bug now.

Dual boot with Windows and windows 10 has fully working audio from all speakers.

0

Try to use alsamixer on your command line and find out which channels are de-/activated.

| improve this answer | |
  • Would you elaborate on how this should be done? – Anwar May 15 '17 at 18:11
  • Of course, open a terminal and type alsamixer, than everything should be self-explanatory. If you don't have alsamixer, get and install it with sudo apt-get install alsamixer. – John Goofy May 16 '17 at 1:05
0

Install alsa tools

sudo apt-get install alsa-tools-gui

hdajackretask

Internal speaker should be on channel group 1, front. 0x14

Checkmark 'show unconnected pins' and 'Advanced override'

Pin 0x16 (check Override) Connectivity blank, Front Location, Jack unknown, Speaker Device, Channel Group 1, Channel (in group) Center/Lfe

Apply now. Install boot override.

sudo sudo gedit /etc/modprobe.d/alsa-base.conf

(add at end of file)

options snd-hda-intel model=asus-mode4

sudo gedit /etc/pulse/daemon.conf

(take out ';' on the line 'enable-lfe-remixing = yes')

ALso, and specify

default-sample-channels = 4 default-channel-map = front-left,front-right,lfe,lfe

Save and reboot computer.

I have a 2.1 configuration (internal speaker Bang & Olfusen and external subwoofer), but in Pavucontrol, I use Analog Surround 4.0 Output + Analog Stereo Input.

| improve this answer | |
  • Doesn't seem to work. I don't have Pin 0x16 available to me. I will try using this tool though to rework things and see if it can help. Thanks for the tip and detailed answer – Dobsgw Jun 5 '17 at 17:18
0

hdajackretask

Also, in alsamixer, press F5 to see your sound levels. Move across with right arrow key. If a level shows 'MM' then press M to un-mute it. If a level is too low, once you are on that channel, press UP-arrow key to increase volume.

| improve this answer | |
0

I know it's late but if anyone have the same problem with Ubuntu on G750 here is a fix. (Problem is still present in 18.04)

Problem: The head speakers are recognized as "Headphone". Ubuntu will mute them, if there is no headphone plugged in. (You can unmute and volume them up in alsamixer)

Fix: You have to force pulseaudio to not mute the channel, if there is no plug in the jack. To do this, open the analog-output-speaker.conf

sudo nano /usr/share/pulseaudio/alsa-mixer/paths/analog-output-speaker.conf

Scroll down to the [Element Headphone] Section and change these lines

[Element Headphone]
switch = off
volume = off

to this:

[Element Headphone]
switch = mute
volume = merge

After reboot or restart pulseaudio (pulseaudio -k) your sound will work fine. Thats it - have fun ;-)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.