1

Hardware: HP2540P laptop OS: Kubuntu 16.04LTS, kernel 4.4.0-72-generic

Since about 12 May 2017 my laptop no longer properly connects to any wifi router on any of the wifi devices I have tried.

I have tried my home router (to which plenty of other things are connected), my phone's wifi hotspot, my work office wifi router (again, other devices are fine there). I have also tried both the internal adaptor and a USB dongle, without success.

The networks are being detected when scanned, and those that are configured for automatic connection get tried, but the connection gets stuck at "Waiting for authorisation" and eventually times out with an error that "No secrets were provided".

Now this worked fine, the day before, and no passwords had been removed or changed. I have tried deleting the connections from Network Manager and rebuilding them from scratch with the passwords and so on, but always with the same result.

Any idea what might have been upgraded or changed to stop the secrets being passed to the router

As requested:

lspci -knn | grep Net -A3
00:19.0 Ethernet controller [0200]: Intel Corporation 82577LM Gigabit Network Connection [8086:10ea] (rev 05)
        Subsystem: Hewlett-Packard Company 82577LM Gigabit Network Connection [103c:7008]
        Kernel driver in use: e1000e
        Kernel modules: e1000e
00:1a.0 USB controller [0c03]: Intel Corporation 5 Series/3400 Series Chipset USB2 Enhanced Host Controller [8086:3b3c] (rev 05)
--
43:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6200 [8086:4239] (rev 35)
        DeviceName: WLAN
        Subsystem: Intel Corporation Centrino Advanced-N 6200 2x2 AGN [8086:1311]
        Kernel driver in use: iwlwifi

Interestingly, the wifi connection is fine if I boot into Windows 7, and also if I boot a USB stick with Kubuntu 14.04.

2
  • Please edit your question and add output of lspci -knn | grep Net -A3 terminal command.
    – Pilot6
    May 15 '17 at 9:04
  • OK, this looks like it's a problem with knetworkmanager, or perhaps it's interaction with kdewallet or whatever is used to store passwords. I removed knetworkmanager completely and was able to get the wifi to work using wpa_supplicant by hand. Then I tried the networkmanager-applet instead, and that seems fine too. Perhaps if I reinstalled knetworkmanager it will work, but i don't trust it...
    – Peter Ford
    May 17 '17 at 13:44
0

Run in a terminal

sudo tee /etc/modprobe.d/iwlwifi-opt.conf <<< "options iwlwifi 11n_disable=8"

and reboot.

2
  • Why would I need that? 11n was working just fine before I had this problem, and it works fine when the interface is brought up manually with wpa_supplicant running
    – Peter Ford
    May 18 '17 at 15:03
  • It does not disable 11n.
    – Pilot6
    May 18 '17 at 16:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.