1

I recently installed XFCE GUI, because I was interested in what it might look like. This changed the wallpaper on my login screen to the standard XFCE greeter.

When I switch back to GNOME, the wallpaper doesn't change back to what it was before, which was the default Ubuntu wallpaper.

I followed the instructions of this post: How do I change the login screen in Ubuntu 16.04+? on how to change the login wallpaper, but to no effect. If I open LightDM, the image selected there is actually the default wallpaper of Ubuntu and I also verified this by going into the folder and looking at the image files. It seems that the XFCE setting is somehow taking precedence over all other settings. I considered uninstalling XFCE, but I would still like to test it.

I have now also completely removed XFCE from my system using this guide: https://www.howtoinstall.co/en/ubuntu/xenial/xfce4?action=remove, and I still can't switch or even get rid of the XFCE greeter wallpaper.

  • It appears that after restarting my computer lightDM is now working. I suspect that there is some setting that needs be to made in the XFCE DE in order to prevent it from taking over the greeter like that. This thread could be removed now as I have sort of answered my question, however if you ignore the last paragraph, then my question is still valid. – insideman May 14 '17 at 13:24
0

Try this:

Open a terminal,

Press Ctrl+Alt+T

Run it:

exec sudo -i
apt-get update
apt-get install --reinstall aptitude deborphan
aptitude remove '?and(?reverse-depends(xubuntu),?not(?reverse-depends(?exact-name(gnome))))'
apt-get install --reinstall gnome
apt-get autoremove
apt-get clean
reboot
0

In my case, what helped, was to edit lightDM config file:

sudo vim /etc/lightdm/lightdm-gtk-greeter.conf

and in section [greeter] adding line:

user-background = false

If you have installed GUI tool for lightDM configuration (sudo apt install lightdm-gtk-greeter-settings) you can achieve the same by ensuring that "Use user wallpaper if available" option is not marked.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.