I have this sound issue ever since Ubuntu 10.x. I am on 11.10 now and I was hoping this would have been fixed.

I would like to use 5.1 speaker sound, so I go to the speaker icon in the top right of the screen and select sound properties, navigate to hardware tab and select 5.1 analog mode. This works wile sound is playing e.g. from Banshee music player. But each time I change a song, the sound is back to 2 channels again.

I have tried the answer from "Sound reverts to 2 channels from 5.1 + Analog", but unfortunately it did not work for me.

I am on 64 bit Ubuntu 11.10. Sound Settings: profile = analog surround 5.1 output. I use a Acer Aspire 8930 laptop (and yes it is ridiculous but it really has a 5.1 speaker system build in).

Somehow Banshee does not remember the 5.1 hardware setting. Each time I change a song manually, it will switch to 2 speaker only, resulting in rather crappy sound.

It seems that overall the sound in my system does use 5.1 speakers.

Does anyone have any ideas?

1 Answer 1


To configure PulseAudio we have two options:

1) Set channels for the daemon

To set the default channels (5.1.) for the pulseaudio daemon we can edit /etc/pulse/daemon.conf as root and edit the following lines to

default-sample-channels = 6
enable-lfe-remixing = yes

Note: Pulseaudio may not run properly if not a valid channel number is given.

2) Set a default card profile

Alternatively we may also define a default sound card profile in /etc/pulse/default.pa (or if defined for a user session only in ~/.pulse/default.pa).

set-card-profile <index> <name>

where we need to give the <index> of the sound card (e.g. 0) and the <name>(e.g. "Digital Surround 5.1 (HDMI)") of the profile we want as default. Possible values are listed with the following command

pacmd list-sinks

Note: for changes to settings files to take effect we need to restart the pulseaudio daemon by

pulseaudio -k

  • thanks I feel kinda stupid since I already set default-sample-channels = 6 but I did not remove the ";" in front of the line. Also I set "enable-lfe-remixing = yes" I read that in another post and it seems be work. So all I needed to change at the end where default sample channels and lfe-remixing.
    – ToonP
    Dec 31, 2011 at 12:10
  • Just used option 1 to get 5.1 USB headphones working on Fedora. Worked perfectly. Apr 17, 2015 at 1:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.