6

When I connect from my home Ubuntu to my office PC the resolution is too great and all the fonts and other screen items are so tiny so I cannot see anything.

This is due to my new monitor at home with 4K resolution. When I connect to Windows 10 I have to choose "use client resolution option" otherwise if I choose "custom resolution" option Remmina makes screen smaller but does not change resolution.

Windows 10 does not allow to change any display setting from a remote session.

What I want to do is to make fonts, icons etc. larger on Windows 10 when I connect to it from Ubuntu 16.04 using Remmina.

Any ideas?

P.S. The left-most icon "Fit remote resolution" is disabled.

2

You should choose "custom resolution" and then set scaling display from toolbar, as I know this is the only usable solution now

2

Recent remmina versions can set RDP remote windows desktop scaling factor. From the global preferences menu -> RDP. But you need an updated remmina version and an OS (windows 8.1 or higher) that supports scaling factor. Upgrade remmina following instructions on the main website http://www.remmina.org. We provide a PPA for ubuntu 16.04. If you already enabled local scaling on your local PC, and usually this is the case when using a 4K monitor, you should also play with the remmina scaler function to neutralize the Xorg/Unity scaling, because remmina can't currently do to it.

2

Better use freerdp.
After you installed it you use it like this from a terminal:

xfreerdp /u:username /p:password /w:1366 /h:768 /v:ipaddress /smart-sizing

The username, password, ipaddress should be the ones of the remote desktop.

Replace the resolution 1366 and 768 also by the resolution of the host. The rdp window scales smoothly.

I tried several other RDP clients, but those did not work.....

0

I could simply scale by using "Toggle dynamic resolution update" menu icon in the floating tab once connected. enter image description here

This fixes my issue

  • This button is greyed out when I connect to macOS. Any idea why that could be? – Tamás Szelei Jan 14 at 14:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.