I have installed Ubuntu Desktop 16.04.2 LTS and want to start firefox from my X11 forwarding ssh session but I get the following error message:

user@user-Virtual-Machine:~$ firefox
Failed to connect to Mir: Failed to connect to server socket: No such file or directory
Unable to init server: Broadway display type not supported: localhost:10.0
Error: cannot open display: localhost:10.0

I am using the latest version of BitVise SSH Client

The settings in my SSH client look like this: click here for X11 client settings

My sshd_config looks like this:

Port 22
Protocol 2
HostKey /etc/ssh/ssh_host_rsa_key
HostKey /etc/ssh/ssh_host_dsa_key
HostKey /etc/ssh/ssh_host_ecdsa_key
HostKey /etc/ssh/ssh_host_ed25519_key
UsePrivilegeSeparation yes
KeyRegenerationInterval 3600
ServerKeyBits 1024
SyslogFacility AUTH
LogLevel INFO
LoginGraceTime 120
PermitRootLogin yes
StrictModes yes
RSAAuthentication yes
PubkeyAuthentication yes
IgnoreRhosts yes
RhostsRSAAuthentication no
HostbasedAuthentication no
PermitEmptyPasswords no
ChallengeResponseAuthentication no
X11Forwarding yes
X11DisplayOffset 10
PrintMotd no
PrintLastLog yes
TCPKeepAlive yes
AcceptEnv LANG LC_*
Subsystem sftp /usr/lib/openssh/sftp-server

What am I doing wrong?

  • Oh, I figured out that this works on an Ubuntu client. Is there any way to make this cross platform compatible?
    – dfsg76
    May 13, 2017 at 11:08
  • What platform(s) are you running it on? Does BitVise SSH Client actually provide an X server, or does it just set up the forwarding for a 3rd party X server - if the latter, what X server are you running? May 13, 2017 at 12:16
  • I manged to get it working using MobaXterm on Windows
    – dfsg76
    May 13, 2017 at 16:38
  • 2
    @pudelwudel How did you configure a) MobaXterm and b) your Ubunut machine. Google lead me to this page, because I also have issues with X11, mobaxterm and Ubuntu 16.04.
    – koppor
    Aug 3, 2017 at 23:12

3 Answers 3


I had the same problem while running firefox on an Ubuntu 18.04 system through MobaXterm. Solution was to install xorg and openbox and then logging in again.

  • 9
    Hi Gh0st. I'm curious to know more about how you came to this solution and why this worked!
    – Hee Jin
    May 7, 2018 at 16:02

Try disabling AppArmor

sudo ln -s /etc/apparmor.d/firefox /etc/apparmor.d/disable/
sudo apparmor_parser -R /etc/apparmor.d/disable/firefox

ref: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=883668


I had the same problem while trying to run firefox on Ubuntu Linux 18 from Windows using SSH. I tried this following and worked fine.

export DISPLAY=username-VirtualBox:10.0

the reason behind it can be realized by running this command :

cat /etc/hosts

for me: localhost sosa-VirtualBox

and when i used "export DISPLAY=localhost:10.0" command, it couldn't capture the screen and GUI it needed for firefox and thus, i received "unable to init server...".

But if you properly define the variable DISPLAY, it captures it from virtual box and you will be good to go.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .