1

In Ubuntu 16.10 and earlier natural scroll settings for touchpad were separatefor mouse and touchpad. Since 17.04 there is only one settings so I can't set it differently for diffrent input devices.

1
  • You can set it separately in libinput that is default in 17.04.
    – Pilot6
    May 13, 2017 at 11:08

1 Answer 1

1

using the gsettings command line api, you should be able to access both i.e. these command line commands will get the current values

$ gsettings get org.gnome.desktop.peripherals.mouse natural-scroll

This returns false for me. for touchpad

$ gsettings get org.gnome.desktop.peripherals.touchpad natural-scroll

Then to change, change the get argument to set and pass a value on the end, e.g.

$ gsettings set org.gnome.desktop.peripherals.touchpad natural-scroll true
            ^^^                                                       ^^^^

and obviously repeat the process for the mouse if you want to change that as well.

4
  • The user asked about natural scroll settings, not speed. Do you have an answer for that?
    – heynnema
    May 13, 2017 at 13:06
  • Doesn't work. They are set diffrent for both devices, but none of them has natural-scroll: kamil@galactica:~$ gsettings get org.gnome.desktop.peripherals.touchpad natural-scroll gets true kamil@galactica:~$ gsettings get org.gnome.desktop.peripherals.mouse natural-scroll gets false
    – Kamil
    May 14, 2017 at 8:53
  • @Kamil do you want natural scroll on or off? you will have to use the second command and set the value you want May 14, 2017 at 8:54
  • I wan't it on for touchpad and off for mouse. It is set like this, but it doesn't work.
    – Kamil
    May 14, 2017 at 11:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .