1

I recently switched my main computer from Windows 10 to Ubuntu 17.04, but have used Firefox for a long time. I have heavily customized my list of search engines, with over a dozen different ones configured, all of which I use frequently. When I was on Windows, I got into the habit of typing into the Firefox search box, hitting TAB until my desired search engine was highlighted, and then hitting Alt+Enter to launch the search in a new tab.

Upon switching to Ubuntu, this workflow stopped working. Initially the cause was the Alt key triggering the HUD instead and preventing Alt+Enter for working at all. I fixed that by following the instructions in the accepted answer to this question, changing the HUD shortcut to Alt+Super instead.

Now Alt+Enter works to launch a search in a new tab, but it's still not fully working; the moment I hit the Alt key, the dropdown containing the search suggestions and alternative search engines disappears (and the menu bar appears in the window's title bar), and the subsequent strike of the Enter key launches a search in the default search engine (instead of my selected engine) in a new tab. The only way for me to search in a non-default search engine is to launch it in the current tab by just using Enter instead of Alt+Enter, but 99% of the time, I need to launch it in a new tab.

I've Googled every combination of search terms I can think of here, and I can only find solutions to the original HUD problem that I've already solved. How do I stop the Alt key from closing the suggestions/engine selection dropdown? This is causing severe disruptions to my workflow and is incredibly annoying, and I need to find a way to stop it and restore my original workflow.

Update: It's now over a month later, and I still have not been able to find a solution to this. Does anyone have even the slightest clue as to how to fix this? This is frustrating me to the point that I have begun seriously considering abandoning every bit of effort I have put into setting up Ubuntu the way I like and going back to Windoze, JUST to get this working again. I really, really don't want to do that, but if I can't find a solution, I may not have any other choice. It is THAT disruptive to my workflow. HELP!!!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.