4

Reminder : I have reinstalled Ubuntu 16.04 from scratch but it didn't help, the problem still exists.


I am using Windows 10 with Ubuntu as dual boot.

The problem is I can not make headphones work. They work just fine on Win 10. Apparently my headphone jack is not compatible with Ubuntu. How can I make Ubuntu see my headphone jack ? I need help please.

Headphone jack not working?

I have tried every method in above link.

Headphones : Apple

When I plug in my headphones they don't even appear: System Settings > Sound

Built-in Speakers are working fine.

If there are other things you want to know, help me to find out please.


Edit: This might be useful.

burakcank@BurakcanK-PC:~/Documents$ lspci | grep Audio
00:03.0 Audio device: Intel Corporation Broadwell-U Audio Controller 
(rev 0a)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset 
High Definition Audio Controller (rev 05)

Edit 2 : Added AlsaInfo


Edit 3 : Added Alsa-base.conf file content

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7

# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-ioctl32 ; /sbin/modprobe --quiet --use-blacklist snd-seq ; }
#
# Workaround at bug #499695 (reverted in Ubuntu see LP #319505)
install snd-pcm /sbin/modprobe --ignore-install snd-pcm $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-pcm-oss ; : ; }
install snd-mixer /sbin/modprobe --ignore-install snd-mixer $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-mixer-oss ; : ; }
install snd-seq /sbin/modprobe --ignore-install snd-seq $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; /sbin/modprobe --quiet --use-blacklist snd-seq-oss ; : ; }
#
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq-midi ; : ; }
# Cause optional modules to be loaded above sound card driver modules
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-emu10k1-synth ; }
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist snd-seq ; }

# Load saa7134-alsa instead of saa7134 (which gets dragged in by it anyway)
install saa7134 /sbin/modprobe --ignore-install saa7134 $CMDLINE_OPTS && { /sbin/modprobe --quiet --use-blacklist saa7134-alsa ; : ; }
# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options saa7134-alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
options snd-usb-audio index=-2
options snd-usb-caiaq index=-2
options snd-usb-ua101 index=-2
options snd-usb-us122l index=-2
options snd-usb-usx2y index=-2
# Ubuntu #62691, enable MPU for snd-cmipci
options snd-cmipci mpu_port=0x330 fm_port=0x388
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
# Keep snd-pcsp from being loaded as first soundcard
options snd-pcsp index=-2
alias snd-card-0 snd-hda-intel
alias sound-slot-0 snd-hda-intel
options snd-hda-intel model=dell-m6-amic
  • Check this question please. Linux is great but there are fewer out of the box options. Anyway you can do almost anything just some extra work may be needed. – Xaqron May 12 '17 at 22:30
  • What type of machine are you on? What do you see when you open the System Settings > Sound? Linux is a great platform for many reasons. However, to get help for an issue on your system you need to provide more information. Here's some tips for asking good questions to get good answers: askubuntu.com/help/how-to-ask – Antonios Hadjigeorgalis May 12 '17 at 23:04
  • @Xaqron I have tried all of the methods stated in that link. I am using Windows 10 with dual boot Ubuntu. The headphones are apple and When I open System Settings > Sound, I can not see my headphones, only the built -in speakers. Again like I said, I have tried every solution in the above link. – BcK May 13 '17 at 16:05
  • Would you please provide AlsaInfo. – Xaqron May 13 '17 at 22:32
  • I have edited the question to include AlsaInfo @Xaqron – BcK May 14 '17 at 18:36
6

Ok after searching for a solution for damn 2 months, I was able to solve my own problem.

By the way this problem also exists in Linux Mint, since they are both based on Debian and that means this is an issue which exists in Debian.

[SOLVED]Front panel headphones not working with onboard Intel HD Audio

Here in this link there is great amount of information about this issue. At some point it mentions from a package hda-jack-retask. I have searched it a little bit and found out that it resides in alsa-tools-gui. Installed it and then I wrote

sudo hdajackretask

In this GUI I have overrided my front jack to headphones and installed boot override.

Now I have crystal clear sounds from my headphones and also it can detect whether they are plugged in or not!! It mutes the speakers when they are plugged in.


I just want to mention that this problem does not occur very frequently among the users maybe, but it is a tough one to solve. The other solutions on the internet just does not work for this issue.

If there is a capable person for noting this issue to be solved in the future versions of Debian, please contact me or show me the way to report this problem.

I hope it helps anyone who has the same problem.

1

My answer was the same as BcK's answer, except I had to override "headphone" to the "line out" port, see the image below. Everything works perfectly now, thanks Bck!

enter image description here

  • Thanks! My answer was similar except some fields (Location, Channel etc.) were different as I had to choose Line out (Back). – yper Aug 26 at 9:46
1

I've found a solution that isn't really a solution...

When I shutdown Windows 10 with the headphones plugged in, the headphones won't work in Ubuntu. When I shutdown Windows 10 without headphones the headphones will work in Ubuntu.

1

I was not able to get it working with above solution. Below one worked. Open terminal, install and open pavucontrol

$ sudo apt-get install pavucontrol
$ pavucontrol

This will open a 'volume control' window. In 'output device' section scroll down to 'Build-in Audio Analog Sterio'. Here change the port to "Headphones(unplugged)"

0

Originally I had a problem with sound back on Ubuntu 14. My notes are cryptic but they mention a volume level of about 2%. Perhaps a package such as pacmd could be useful? Further in my old notes is a command sudo pacmd set-sink-volume 32600. There is also a comment to be sure muted:no (don't know if that is also part of the pacmd stuff.

0

Try to mute and unmute via function panel (my ntb fn + f10). After that my sound settings sync and my headphone started works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.