87

None of the HDMI output are working, all saying "dummy output", it was working yesterday, but when I use the headphones it became soundless, with or without the headphones. Thank you already!

1
  • You can check your default output device and also configure multiple device outputs following this guide : askubuntu.com/questions/78174/… reboot in between enbling it and choosing the output type. – tatsu May 12 '17 at 12:19
118

I had a similar issue happen where suddenly (I have no idea what I updated, or what changed in the system) I could not get sound.

I did the whole pulseaudio -k && sudo alsa force-reload thing. I didn't have any cards listed from pacmd list-cards but I could see the device with commands like:
lspci -nnk | grep -A2 Audio

I even installed a newer kernel (4.8+ since it apparently has good support for my particular machine).

In the end, I rebooted into the bios and disabled the built-in audio, applied those changes, rebooted to Ubuntu, then rebooted again into the bios to re-enable the audio. Once back into Ubuntu after that, everything seemed to work great!

Don't know if this will help with other people looking for solutions to their problems. I was using a Dell XPS 13 (9350), but might be something for others to at least try.

14
  • 71
    Running pulseaudio -k && sudo alsa force-reload was enough for 17.10 to show my card again when running pacmd list-cards. Thank you – springloaded Nov 18 '17 at 2:12
  • 4
    pulseaudio -k && sudo alsa force-reload also worked for me – bawa g Feb 13 '18 at 6:13
  • Thanks a lot! This was the only answer I found worked for my on my Dell Precision! – apieceofbart Mar 26 '18 at 8:46
  • 8
    Just pulseaudio -k and then waiting for 5 seconds automatically restarted the sound daemon, while headphones were connected all that while. – Ashish Jul 20 '18 at 20:40
  • 2
    working for dell. bios->disable audio -> boot to ubuntu -> restart -> bios -> enable aduio -> boot to ubuntu – bawa g Aug 13 '18 at 13:08
10

Update: I forgot you're required to have 10 points to do that. Try this.

pacmd list-cards

From there locate your audio device, and set it as the default.

An example of this would be something like

pacmd set-card-profile 2 output:analog-stereo

You can find more information on this in the following link.

Change default sound device

Unfortunatley it's difficult for me to really help you out without either some form of terminal output or a picture, a list of steps you've taken etc..

So another thing you could do is (this will make sure you get to where I tell you to go)

Open your terminal and type

unity-control-settings

That command opens the system settings. From there go to hardware section (middle) and select Sound/Sound Settings.

I'm sure you did this already, this is what I was saying before. Just to make sure we cover the basics I'll add it in again any way.

Go through each tab Output, Input (mainly those two), Sound effects, and applications. Select and set the default audio device (just click on it). You can even test the sound to verify it's there.

The reason I bring this up again is because you say it happened after you used headphones which sounds like the default device was changed.

Make sure if you're using any form of external hardware the required drivers for them are in fact installed. If you still cannot get sound, Send me a Private message with a picture or some terminal out put.

7
  • In profile there is only HDMI options. Thereś no PCM option. It detect's audio device and that's all. There's no options to choose. – BUBI May 12 '17 at 14:40
  • When you go to the sound settings where you can select the default devices for playback recording etc.. you're not seeing your output device? It's possible it's a bad driver or it was somehow disabled. Can you provide some form of terminal output or an image? – Afflicted May 12 '17 at 14:46
  • I've tried to put a image, but it says that I have to get 10 points. Is there another way for me to send it? – BUBI May 12 '17 at 21:25
  • Thank you! It turn out to be something more, the problem was in the computer, I call Dell and they sent a support, they change the motherboard, now is working. Thank you very much for your help! – BUBI May 20 '17 at 0:16
  • Sorry I couldn't have been more help. I'm glad it worked out for you though! – Afflicted May 20 '17 at 0:17
5

Same happened to me, on Display Port, with audio from GTX 1650.

This worked for me:

pulseaudio -k && sudo alsa force-reload

upon further tests: just the pulseaudio -k alone does it, but takes 5 secs or so. I need to do this every time after waking up my PC. Ubuntu 20.04.1 LTS.

1
  • Thanks a lot! It worked also for me. – mohamed_18 Dec 15 '20 at 20:29
2

working for dell +2. Mine is Dell inspiron 5570. bios->disable audio -> boot to ubuntu -> restart -> bios -> enable aduio -> boot to ubuntu

1
  • Unfortunately, this didn't do the trick on my Dell XPS 7390. :( – balu Jul 6 '20 at 13:41
0

working for HP Spectre with Ubuntu 18.04. bios->disable audio -> boot to ubuntu -> restart -> bios -> enable audio -> boot to ubuntu

0

I had a similar problem. There was no sound output from my laptop out of blue. Increasing or decreasing the volume showed on the screen - 'Dummy output' getting increased or decreased.

I rebooted the laptop and everything was working fine again.

-1

Technically speaking the sound disappeared in the new accounts that have been created on the same machine and the same Ubuntu Version. The weird part is that no particular changes have been made to any of those accounts. By that I mean some files were copied from one folder to an other. No change in addition from the main (admin/ root) account either. The sound kept disappearing progressively from every account which is not root. I created a new account just to see what would happen. The sound disappears after a couple of hours.

To fix that some methods require a sudo privileges. Yet it doesn't work with the users which aren't "sudoers". To be more precise they aren't in the sodoers file.

And for some reason the computer "see's" the soundcard while the soundmixer doesn't seem to.

The weirdest was after. The sound came back as unexpected as it left. Yes, I unchecked the members (users) from the audio group (whom I started to put in after the sound disappeared) and yes, I restarted the computer from the main account. It seems that the issue might come from the way the user have been logged out the one's from each others.

Not the answer you're looking for? Browse other questions tagged or ask your own question.