62

When I right click the Filezilla icon, the only options are "launch" and "properties". How do I remove it from the top panel?

enter image description here

  • I don't have the points to post an official answer, but one way to address this for Ubuntu 18.04 is to use the Icon Hider GNOME Extension: Open Firefox. Visit addons.mozilla.org/en-US/firefox/addon/gnome-shell-integration. Click “Add to Firefox”. Install this package to enable it: sudo apt install chrome-gnome-shell. Then use Firefox to visit extensions.gnome.org/extension/351/icon-hider. Flip the switch from OFF to ON. Now a small icon with 4 squares will appear in the top right of your screen in the GNOME panel. Left click on it to toggle icons to hide. – Aaron Gray Aug 19 at 21:01
95

You are using the Gnome-Classic interface - either you are using this by choice, or you are using the fallback mode which occurs if your graphics card & driver doesnt the 3D Acceleration required for the full Gnome-Shell GUI.

To add and remove application launchers in the gnome-panel you need to:

Press Win+Alt and right-click the top menu bar - N.B. Win is the Windows Symbol key

If you are not using Compiz then you need to :

Press Alt and right-click the top menu bar

Much more information is described in the linked Q&A and other links in that answer.


Linked Question:

  1. How to revert to GNOME Classic Desktop?
  • 1
    Doesn't work for me. – squashed.bugaboo May 25 '15 at 6:32
  • It does not work when dconf: org.gnome.desktop.wm.preferences.mouse-button-modifier is not <Alt>. I usually use <Alt><Super> and can't to remove something. – vp_arth May 18 '17 at 7:44
24

Hold Alt while right-mouse clicking on the said icon.

A menu should then appear giving you the options to either move it or remove from panel.

0

Try

Worked on Ubuntu 16.04

gsettings set org.gnome.gnome-panel.lockdown locked-down false

  • worked for me in 16.04 – Vijay Oct 26 '18 at 6:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.