0

I'm stuck in installing (any versions between 16.04 LTS - 17.04 tried) Ubuntu. The machine (Lenovo 27" A7 Series) has as OS CentOS7 (minimal), want to obviously install Ubuntu on it.

What I did until now

  • Created USB Stick (FAT32) with UNetbooting and Etcher (workaround on mentioned Ubuntu versions above)
  • 1 USB Stick is a USB2.0 the other an USB3.0
  • Running machine booting USB Stick
  • Installation modes are coming up
  • tried to install in different ways (try ubuntu, instal, OEM etc.)
  • tried to update the Kernel from 3.10.0 up to 4.11.0
  • Ubuntu Installation Screen shows sometimes up (Language) than freezed

Result is still

  • (initramfs) Unable to find a medium containing a live file System Screen freezes with a Flashing cursos at the end line.

If I'm running machine normally on CentOS can't access to command line (to at least work around the system) due I tried install a GNOME Desktop, because of the frustration that wasn't / isn't working.

Now

I'm stuck in a system that can't install a new OS and an OS I can't handle without terminal access.

Setting up BIOS isn't changing that much, just the initialisation to boot device can be managed.
Someone has some proper solutions for this issue, I would much appreciate to finally could at least run the installation.

Thanks in advance.

1

Alright. Heres what I do to make sure things go right.

  • Stick with usb 2.0 ONLY
  • Find out which partitioning sheme GPT or MBR your current drive is in. this step can be skipped if the SSD/HHD you plan to install to has no partitions that you wish to keep.
  • Create the USB key :
    • Simply download this.
    • Format your USB 2.0 key to FAT32 using gparted.
    • (Still in Gparted) Right click on the visualised partition and select "manage flags" tick "boot" and apply.
    • Now simply mount the iso by double cliking it (this should open it's folder).
    • CTRL-A
    • CTRL-C
    • Go into the still-mounted folder of the formatted USB 2.0 key.
    • CTRL-V
    • Reboot and go into BIOS (make sure UEFI boot is enabled and) reorder boot priority so as to hav the USB (in UEFI mode first) save a restart.

Let's stop here for now tell me if this succeded but really from there everything else should be more or less intuitive.

  • First thanks for your fast reply. I should mention, I'm working on a MacBook Pro... so I won't be able to gparting the partition unless unsing Diskutil which works fine. After this step I can't rella understand what you mean where I have to select these folders. "managed Flags" and "boot" can't be selected anywhere! BTW. having same issue following (on Mac) your advice. – Gianni May 12 '17 at 10:05
  • uhm not to contradict you but have you tried this : sourceforge.net/projects/gparted/files/gparted-live-stable/… – tatsu May 12 '17 at 10:10
  • also on mac you can do this with fdisk : fdisk /dev/sdd replace "sdd" with corect device. then type a if there's one last step it should be 1 (because first partition) but other than that congrats you've added the "boot" flag to your usb key making it bootable! – tatsu May 12 '17 at 10:16
  • thanks for your reply. gparted can't be run on my machine, or at least I don't know how to run an iso on my machine, due DiskImageMounter on mac is not opening the app you've provided form Sourceforge (no filesystem could be bound). It just get to complete it's own process on Terminal. Btw.. Trying with fdisk (more comfortable) and encountering same mentioned error of this thread. :( – Gianni May 12 '17 at 10:38
  • fdisk fails to mark the usb key as bootable? did not did you continue by extreacting the iso I provided to the usb key and attempting to boot to it? – tatsu May 12 '17 at 11:44
0

My main problem was "initramfs" message, so I'll limit myself to describe the solution for installing Ubuntu on a "Levovo A740" (which should workd on all machines). I got a proper solution after testing around, wich is a simple unselect of some APIC's.

  1. Create a bootable UBS Drive (be sure you create A FAT32)
    Grab your copy of Unetbootin OR Etcher

  2. Install Ubuntu

Once you normally restart your system with insert Bootable UBS Stick you got the Ubuntu Installation Screen as this:enter image description here

HOTFIX!!!
1. Press F6 and select with SPACE BAR the noapic and nolapic
2. press ESC after you're made the selection on list
3. Select "Try Ubuntu without installing" -> Machine will run like a VM.

You'll now on the main Ubuntu Desktop!
Select the Ubuntu Installation image you'll find on Desktop following the common installation procedure.

enter image description here

After you're installed Ubuntu system restarts and you'll get this screen: enter image description here

Remove your USB device and let system Restart.
Congratulation you're running Ubuntu on your machine!

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.