1

Good morning all,

i have a little issue that has been puzzelling me for a bit,

i have an ubuntu server now with a fresh clean and updated install of 16.04.2 LTS and when i go to shutdown or reboot using the usall reboot / poweroff command or if at lock screen with alt-ctrl-del

i get reached target shutdown after 120 seconds in an never ending loop,server showing target shutdown reached but stuck at it

update - 3 hours later

i would like to add that i also added the intel micro-code by running:

sudo apt-get update
sudo apt-get install intel-microcode

also till now the only method i got the server to reboot and off is by appending -f to poweroff and reboot commands, how ever this server is meant to be at a remote site, and i will not always be able to go to said site to powercycle the server. if anyone may help i am deeply thankfull.

temp fix - hacking of grub

To fix my problem, I had to edit the /etc/default/grub config file and added acpi=force apm=power_off to the config line, between the double quotation marks…

GRUB_CMDLINE_LINUX_DEFAULT=""

and

GRUB_CMDLINE_LINUX=""

do a update-grub after saving then reboot one more time.. ( force restart when it hangs ) After the restart, try another reboot, it should work now without hanging.

Update - issue still persisting.

0

I had same problem with Ubuntu server 16.04.2 on Raid 1 in Dell PowerEdge T20. I tried tuning systemd, switching kernel versions to 4.8 and 4.9, updated BIOS, added acpi=force to GRUB BOOTOPTIONS but nothing helped.

Finally I solved this by wiping hard disks (dd if=/dev/zero of=/dev/sdX bs=4096) and setting up software RAID1 using Ubuntu installer. Now I don't have any issues while shutting down or rebooting system.

Linux softRAID is generally better solution than fakeRaid, in this case too.

  • current install is on Linux soft raid with md 0 for swap and md1 for ext4, still surprised it dose not shutdown right as its not on fake raid. and up-to-date with all updates. – warmax356 Aug 14 '17 at 12:53
  • @warmax356 you need to be sure that drives were not prepared by fakeraid before installing softraid. It's not enaugh to just turn off fakeraid in BIOS, you need to wipe hard drives. – Māris Kiseļovs Aug 15 '17 at 15:53
  • as far as i remember the drives where installed and used the Ubuntu installer to create the raid, will need to check if fake raid is still in effect when i am at the remote site now. – warmax356 Aug 21 '17 at 6:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.