0

When I open my file manager on (Ubuntu 16.04, GNOME3 DE) normally as in (nautilus or xdg-open "directory name" I get a very messed up layout (rendering problem I guess, Ctrl+L also doesn't work to see/change the path).

But when I open it as root (sudo nautilus) I get a whole different design/look/feel (The one I want to open normally)

How can this be happening? I want to to able to use the second design. What should I do?

PS: Following is the output

$ dpkg-query -Wf '${Status;1} ${Package}\n' gnome-shell\* gnome-themes\* | sed -ne 's/^i //p' | xargs -rd'\n' -- apt-cache policy
gnome-shell:
  Installed: 3.20.4-0ubuntu2~ubuntu16.04.1
  Candidate: 3.20.4-0ubuntu2~ubuntu16.04.1
  Version table:
 *** 3.20.4-0ubuntu2~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu xenial/main amd64 Packages
        100 /var/lib/dpkg/status
     3.18.5-0ubuntu0.2 500
        500 http://in.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
     3.18.4-0ubuntu3 500
        500 http://in.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
gnome-shell-common:
  Installed: 3.20.4-0ubuntu2~ubuntu16.04.1
  Candidate: 3.20.4-0ubuntu2~ubuntu16.04.1
  Version table:
 *** 3.20.4-0ubuntu2~ubuntu16.04.1 500
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     3.18.5-0ubuntu0.2 500
        500 http://in.archive.ubuntu.com/ubuntu xenial-updates/universe amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu xenial-updates/universe i386 Packages
     3.18.4-0ubuntu3 500
        500 http://in.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
gnome-themes-standard:
  Installed: (none)
  Candidate: 3.20.2-1ubuntu1~xenial1
  Version table:
     3.20.2-1ubuntu1~xenial1 500
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu xenial/main amd64 Packages
     3.18.0-2ubuntu1 500
        500 http://in.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
gnome-themes-standard-data:
  Installed: 3.20.2-1ubuntu1~xenial1
  Candidate: 3.20.2-1ubuntu1~xenial1
  Version table:
 *** 3.20.2-1ubuntu1~xenial1 500
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu xenial/main amd64 Packages
        500 http://ppa.launchpad.net/gnome3-team/gnome3-staging/ubuntu xenial/main i386 Packages
        100 /var/lib/dpkg/status
     3.18.0-2ubuntu1 500
        500 http://in.archive.ubuntu.com/ubuntu xenial/universe amd64 Packages
        500 http://in.archive.ubuntu.com/ubuntu xenial/universe i386 Packages
  • Ubuntu gnome should have second look by default – Sumeet Deshmukh May 12 '17 at 7:08
  • This is a theming issue. Could you please either shrink the size of the Nautilus window (so that it isn't maximized) or disable the function that fuses its tool bar to the Gnome Shell status bar? The super-user account doesn't use that theme so it's not affected by the issue. – David Foerster May 12 '17 at 7:08
  • @DavidFoerster minimizing didn't change anything.. I am using 'Adwaita' theme. How do I disable the function you mention about? – Sudip Bhandari May 12 '17 at 7:11
  • I'm not sure exactly how to disable that. I think it's either a Gnome Shell extension or a Gnome Shell Theme. You can try to disable all extensions and switch to a different theme to confirm that. Both can be done with gnome-tweak-tool. – David Foerster May 12 '17 at 7:18
  • 1
    You should not use sudo nautilus, use pkexec nautilus instead. – mook765 May 12 '17 at 7:26
1

This looks like it's a theming issue related to the Gnome Staging PPA. Please revert to the stock version of Gnome:

  1. Install ppa-purge:

    sudo apt install ppa-purge
    
  2. Log out of your graphical user session.

  3. Switch to a virtual terminal (Ctrl+Alt+F1) and log in there. We're going to replace the graphical environment so let's better not use it while we do that.

  4. Purge the Gnome Staging PPA:

    sudo ppa-purge ppa:gnome3-team/gnome3-staging
    

    This will probably take a while. For more info see How can PPAs be removed?

  5. Reboot.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.