I recently upgraded from Kubuntu 16.10 → 17.04. After the upgrade, the Courier 10 Pitch font now appears to be "missing".

How can I recover/reinstall the Courier 10 Pitch font and/or force LibreOffice Writer to see it?

The font is, supposedly, included in the xfonts-scalable package, but removing/purging and reinstalling this package makes no difference. It was definitely showing up under 16.10, too.

NOTE: apt-cache show xfonts-scalable does not list included fonts by name, so I couldn't confirm it's really there; I had simply read that it's supposed to be there elsewhere.

Interestingly, the fc-list command appears to claim the font is available:

fc-list "Courier 10 Pitch"                                           
/usr/share/fonts/X11/Type1/c0419bt_.pfb: Courier 10 Pitch:style=Regular
/usr/share/fonts/X11/Type1/c0611bt_.pfb: Courier 10 Pitch:style=Bold Italic
/usr/share/fonts/X11/Type1/c0582bt_.pfb: Courier 10 Pitch:style=Italic
/usr/share/fonts/X11/Type1/c0583bt_.pfb: Courier 10 Pitch:style=Bold

However, LibreOffice Writer still shows the font as "not installed". (See pic. at bottom.)

The apt-cache show ttf-mscorefonts-installer command lists Courier New (Bold, Italic, Bold Italic) as being part of it, so I also tried removing/purging that package and re-installing, which works fine (see partial output below). However, that seems to only contain the Courier New version of it and does not include Courier 10 Pitch.

Extracting cabinet: /var/lib/update-notifier/package-data-downloads/partial/courie32.exe
  extracting cour.ttf
  extracting courbd.ttf
  extracting courbi.ttf
  extracting fontinst.inf
  extracting couri.ttf
  extracting fontinst.exe

All done, no errors.

I've tried the sudo fc-cache -fv command to see if it's a caching issue, but it made no difference.

Contents under /usr/share/fonts/ only show the Courier New font as being present, not Courier 10 Pitch. Other than the font and sym-links pointing back to them (see below), there're no additional matches for 'Courier'.

lrwxrwxrwx 1 root root   20 May 11 21:21 courbd.ttf -> Courier_New_Bold.ttf
lrwxrwxrwx 1 root root   27 May 11 21:21 courbi.ttf -> Courier_New_Bold_Italic.ttf
-rw-r--r-- 1 root root 230K May 11  2000 Courier_New_Bold_Italic.ttf
-rw-r--r-- 1 root root 305K May 11  2000 Courier_New_Bold.ttf
-rw-r--r-- 1 root root 239K May 11  2000 Courier_New_Italic.ttf
-rw-r--r-- 1 root root 296K May 11  2000 Courier_New.ttf
lrwxrwxrwx 1 root root   22 May 11 21:21 couri.ttf -> Courier_New_Italic.ttf
lrwxrwxrwx 1 root root   15 May 11 21:21 cour.ttf -> Courier_New.ttf

If it makes a difference, the /usr/local/share/fonts/ directory is empty.

Note the font not being listed under Family and the "font has not been installed" message below the Language drop down menu label.

Missing Courier 10 Pitch Font


Here is the manual installable font to install Courier 10 Pitch from 3rd party


The tar is located here for Courier 10 Pitch

-----Courier 10 Pitch is in the font-bitstream-type1 tarball-----


  • This does not work. As already noted in my original post, I already have xfonts-scalable installed, and reinstalling has made no difference. The xfonts-100dpi and xfonts-75dpi and xfonts-cyrillic make no difference either. It doesn't look like they even claim to have the Courier 10 Pitch font, so why did you expect them to make a difference? – code_dredd May 12 '17 at 6:32
  • That package does not show up. In what repository is xorgs-fonts-type supposed to be and does it say that it has the font I'm looking for? – code_dredd May 12 '17 at 6:40
  • I'll consider your answer for acceptance simply b/c it allowed me to find/install the font manually. I'll give it some time to see if someone has a better alternative. Some of the issues with this answer are that it ignores the fact that the font is present "out-of-the-box" in 16.xx versions, that the license cited does not really restrict the font's inclusion (i.e. it's not the cause for it being missing in 17.04) and makes some factually incorrect statements about it, and that the solution goes outside the distro's package manager, which is usually the preferred method for several reasons. – code_dredd May 12 '17 at 8:10
  • @code_dredd As discussed in the bug report the other answer refers to, LibreOffice 5.3 removed support for the Type 1 font format, meaning it can't use the fonts in the xfonts-scalable package. So one workaround is to use the font in a supported format, as linked to by this (revised) answer. – chrstphrchvz Mar 19 at 3:02

I had the same problem only when updating to LibreOffice 5.3. And also with the Bitstream Charter font. Because updating to Ubuntu 17.04 also updates to LibreOffice 5.3... maybe that's the root of the issue.

You could try the issue using Calligra Words. In my case, Courier 10 Pitch (which is much better than the spindly, lumpy, and just plain ugly Courier New) stopped working when using LibreOffice 5.3 but kept on working when using Calligra Words. That made me think.

Instead of using Courier 10 Pitch in LibreOffice 5.3 I started using an improved version of the font, named Courier Code (http://www.linux-magazine.com/Online/Blogs/Off-the-Beat-Bruce-Byfield-s-Blog/Free-equivalents-for-standard-proprietary-fonts , https://fontlibrary.org/en/font/courier-code). This way we avoid adding another "Courier 10 Pitch" font equally named; we have the same advantage with Charis SIL (https://fontlibrary.org/en/font/charis, http://packages.ubuntu.com/charis) when installing it instead of another font also named Bitstream Sans.

There's more information in a LibreOffice bug report.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.