2

I want to use gammu for using my web-stick, i. e. getting information about my account and loading up my account. In other words I’m interested in sending USSD-requests and reading the answers I get.

Info:

  • system: Lubuntu 16.04.2 LTS (64bit)

  • Bus 001 Device 016: ID 12d1:1001 Huawei Technologies Co., Ltd. E169/E620/E800 HSDPA Modem

  • usb-modeswitch: installed

  • gammu 1.37.0-1build1: installed

  • .gammurc in home directory with

     port = /dev/ttyUSB2 
     model = 
     connection = at
     synchronizetime = yes
     logfile = 
     logformat = nothing
     use_locking = 
     gammuloc =     
    

When typing in sudo gammu -c ${HOME}/.gammurc getussd "*100#" (checking my credit balance) I get something like

no feedback within specified time. Timeout. Possibly phone disconnected.

Yet my web-stick is connected. The same happens with sudo gammu --getallsms.

  • With what exactly do you need help? What are you trying to achieve? – David Foerster May 11 '17 at 18:04
  • Hi. Well, I just want to use gammu to load up my account/checking my credit balance. Therefore I need to send USSD-requests. Yet that seems not to be possible as I get "no feedback within specified time. Timeout. Possibly phone disconnected." Then my terminal closes. – Rosika May 12 '17 at 14:02
  • Have you tried any of these other methods? askubuntu.com/questions/391320/… – Anwar May 18 '17 at 14:16
  • Hi Anwar. Tnx for the suggestion and links. I´ve tried "modem manager gui" and I have to say it works fine and meets all my needs. Tnx again for your help. Rosika – Rosika May 21 '17 at 10:30
  • @Rosika wait! Did modem manager gui worked for ussd? – Anwar May 25 '17 at 14:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.