1

Issue

Background

Had no issues previously, with the same base box and config, but now on new laptop (Dell Latitude 5580) and Ubuntu 17.04. Previously was on Dell Latitude E5xxx with Ubuntu 16.04.

Steps I've Tried

  • Latest versions of Vagrant and VirtualBox (.deb downloads)
  • Official Zesty versions of Vagrant and VirtualBox (aptitude packages)
  • Removing host only network in VirtualBox and allowing it to be recreated by Vagrant
  • Made sure firewalls (ufw) were disabled in both host and guest
  • Tested with another base box, running Ubuntu 14 - same result
  • Tested with a Windows Box (manually configuring interface) - same result
  • In my case ifconfig command was unavailable on 17.04 which is apparently needed by vagrant/vbox to set up interfaces. sudo apt install net-tools resolved it – Attila Fulop Jul 10 '17 at 15:59
2

It seems, that host kernel modules aren't installed or virtual box drivers are missed just like vboxnetflt. More about this you can find in a section of 2.3.2. The VirtualBox driver modules.

To prepare more diagnostic informations, please verify loaded kernel modules.

$ lsmod|grep vbox
vboxpci                24576  0
vboxnetadp             28672  0
vboxnetflt             28672  1
vboxdrv               462848  5 vboxnetadp,vboxnetflt,vboxpci

Please check also avability of virtualbox network inteface (vboxnet).

$ ifconfig 
[...]
vboxnet0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.56.1  netmask 255.255.255.0  broadcast 192.168.56.255
        inet6 fe80::800:27ff:fe00:0  prefixlen 64  scopeid 0x20<link>
        ether 0a:00:27:00:00:00  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 398  bytes 50684 (50.6 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

If you use virtulabox from packages delivered straight from ubuntu the solution is installation of virtualbox-dkms package and recreation of a vboxnet0 (host-only network). Please remember to edit the patrameters of vboxnet0. After this step you'll push ok button and vboxnet0 will appear on ifconfig list.

  • 1
    Wow, thanks so much @TomWiz ! I had tried sooo many things, but this got me the last step of the way. I had tried removing the host network, but had not thought to try creating manually (vs. letting vagrant/vbox do it) and that seems to have been the magic bullet. kernel modules and dkms were all good to go, but I guess I must have done something in the wrong order previously, or is this just an issue introduced by Ubuntu 17? In any case, I am very grateful for your help! – chrisputnam9 May 16 '17 at 15:01
  • How do I recreate vboxnet0 manually in my ubuntu guest? I have a vboxnet0 and an ip address on my ubuntu host (I added the IP on the host manually with ip a add 192.168.33.1/255.255.255.0 dev vboxnet0 – Lotus May 30 '17 at 21:42
  • On Ubuntu 17.04, editing the settings for the vboxnet0 in Virtual Box (not actually changing anything), and pressing "OK" was enough for the vboxnet0 interface to show up in ifconfig. Weird bug, I hope it gets resolved in a future release. – springloaded Jul 8 '17 at 14:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.