0

This question already has an answer here:

I used to access files by typing \\\fileserver2 in run command in windows. How do I access them in Xubuntu 16.04 LTS?

I tried using ftp://fileserver2 in terminal but it said there is no such directory.

I am new to Linux so I have no idea. I followed the answer to "Access to network files under \\directory" but it didn't work.

marked as duplicate by David Foerster, Eric Carvalho, user364819, Anwar, Ravexina May 13 '17 at 15:36

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • no i used smb://fileserver2 but it dint work either. – Mahima Jain May 10 '17 at 20:12
  • 1
    What's the output of ping fileserver2? Through which protocol(s) does it grant file access? FTP? SFTP? SMB/CIFS? – David Foerster May 10 '17 at 23:44
0

If you want to mount your FTP server so you can access it via GUI, do the following (this is probably the most convenient solution):

Install curlftpfs. Open a terminal and type:

sudo apt-get install curlftpfs

Create the directory you want to mount your FTP server to, for example

mkdir /home/username/fileserver2

Then mount it with

curlftpfs username:password@fileserver2 /path/to/your/created/folder -o allow_other,disable_eprt

Or if you want a SSL/TLS encrypted connection

curlftpfs username:password@fileserver2 /path/to/your/created/folder -o allow_other,disable_eprt,tlsv1

If you dont need it anymore, use

fusermount -u /path/to/your/created/folder

to unmount it.

Alternatives:

  • Use a FTP client like FileZilla
  • Use the terminal: sudo apt-get install ftp and then ftp servername. To learn how to use it look at the manpage via man ftp
  • "Error connecting to ftp: Failed to connect to fileserver2 port 21: Connection refused" This is what i got when i tried to mount it. What can i do now. – Mahima Jain May 10 '17 at 20:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.