3

In a new system install (this has not happened to me before, and all my systems are Xubuntu 16.04 64bits, like this new one), both Chromium and Chrome at start throw a window to me asking something like this (translated on the fly from Spanish) "One application wants to access the passwords storage 'Default' but it is locked", it is asking about the keyring, I guess. I enter my user password and it complains that the password is not valid, this new window does not dissappear unless I click Cancel many times.

There are several questions even here in AskUbuntu about how to disable it (so do not flag this question for that, please). But as far as I know, if I disable it (keyring), the browsers will not be able anymore to save my web passwords in encrypted format.

So my question: how to fix this right? I don't just want to get rid of the message, I want to configure it right so both browsers will be able to store my websites passwords in a secure manner and don't prompt me about it anymore when I launch the browsers.

Thanks

  • Did you use autologin? In Xubuntu 18.04 have this only, if I setup autologin in LightDM confuguration. – jarno Sep 22 at 14:32
1

"But as far as I know, if I disable it (keyring), the browsers will not be able anymore to save my web passwords in encrypted format."

Not at all

The keyring is just to distinguish different users that may or may not have access to the session.

basically office multi-user machine vs. personal computer. which case are you in? I'm guessing the former.

in which case entering a blank password is the right way to go for you if you are the only user on your system and that noone needs to SSL or other to a session on your machine.

the answers on internet are correct for your case :)

  • Thanks for the info, yes this will be a one person laptop. – AlexN May 10 '17 at 13:25
  • Well, now I disagree. I launched Chrome later (after removing with seahorse the Default keyring folder), Chrome prompted me again with the password. Initially I left it blank and continued, and Chrome warned me with exactly what I was afraid of, it said that if I leave it blank, my web passwords will not be secured and everyone will be able to see them. Luckily this time this was the window format that allows me to set the password, so I entered my user password. (I dont know if I should have set a different password) but at least it looks more secure than not encrypting them at all. – AlexN May 10 '17 at 21:58
  • everyone on your computer also I never said to remove the default keyring folder I just said to enter an empty password. – tatsu May 11 '17 at 7:02
  • The Default keyring folder was created again by the system, I had seahorse open and could see it, and that warning happened when I tried to leave the password blank, that is when the system warned me that leaving it blank would create that security risk. – AlexN May 11 '17 at 9:37
  • exactly : so leave it blank; there'll be a keyring folder with that blank password. People on your system (AKA you) will be able to access your personal chrome session so it's not secure if you were to let more people connect to your session but you won't so everything's the way it should be. – tatsu May 11 '17 at 9:40
0

I had a similar problem on Debian Jessie. I use XFCE desktop and gdm3. I found that by going into the Applications Menu -> Settings -> Session and Startup -> Advanced and select Launch Gnome Services on Startup solved the problem.

  • I found this quite helpful, don't know why it was downvoted. For me, I activated Secret Storage Service (Gnome Keyring: Secret Service) and SSH Key Agent (Gnome Keyring: SSH Agent) Xubuntu 17.04 – Tim Richardson Sep 18 '17 at 3:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.