0

I'm experiencing the infamous wireless connection drops with my Realtek RTL8821AE adapter. I've just installed Ubuntu 17.04 (Budgie, FYI), with kernel 4.10. I've tried updating the wireless driver using lwfinger/rtlwifi_new git repository, but the issue is still there.

For testing purpose, I've taken my laptop at work, connected to an access point and left there pinging google. It's a couple of hours that the ping is working, while at home it drops every couple of minutes. This made me think about something router-related. Although the wireless works flawlessly from Windows 10 with the same router.

Is it possible? Any idea about some router configuration that can cause such behavior?

Anyway, I think that the wireless card driver/firmware is still playing an important role in this issue. Maybe it's something driver+router related. If this can even be possible...

1

It is quite true that the router and its interaction with the wireless device and driver are crucial.

I would be certain that the firmware for your router is fully updated. Often, bugs are discovered and corrected and the fix will only appear if you update the firmware to the latest available.

Second, I suggest that you disable power saving in Network Manager. From the terminal:

sudo sed -i 's/3/2/' /etc/NetworkManager/conf.d/*

Next, check the settings in the router. WPA2-AES is preferred; not any WPA and WPA2 mixed mode and certainly not TKIP. Second, if your router is capable of N speeds, you may have better connectivity with a channel width of 20 MHz in the 2.4 GHz band instead of automatic 20/40 MHz, although it is likely to affect N speeds. I also have better luck with a fixed channel, either 1, 6 or 11, rather than automatic channel selection. Also, be certain the router is not set to use N speeds only; auto B, G and N is preferred. After making these changes, reboot the router.

Next, I recommend that your regulatory domain be set explicitly. Check yours:

sudo iw reg get

If you get 00, that is a one-size-maybe-fits-all setting. Find yours here: http://en.wikipedia.org/wiki/ISO_3166-1_alpha-2 Then set it temporarily:

sudo iw reg set IS

Of course, substitute your country code if not Iceland. Set it permanently:

gksudo gedit /etc/default/crda

Use nano or kate or leafpad if you don't have the text editor gedit.

Change the last line to read:

REGDOMAIN=IS

Proofread carefully, save and close the text editor.

Next, I'd set IPv6 to Ignore in Network Manager: http://docs.fedoraproject.org/en-US/Fedora/18/html/Installation_Guide/images/netconfig/network-connections-ipv6-ignore.png This example is for ethernet, but you want wireless.

  • Thanks for your detailed answer. I'll do some test this very evening. The fact that on Windows it is working correctly still bugs me; looks more like the problem is on Linux side, not on the router. The regulatory hint is really interesting; I've always installed english versions, so maybe there are settings not fully compatible with italian regulations (i.e. router settings). News soon... – il_mix May 10 '17 at 13:09
  • Awfully, at the moment I'm using my provider modem, that doesn't provide configurations for channel width. Encription can only be WEP or WPA-PSK. I've set the regulatory domain to IT, but again no luck. Note that I'm using the default kernel driver again (reinstalled the OS). I'll try re-installing the new one. – il_mix May 10 '17 at 21:05
  • Are there any clues in the log? dmesg | grep rtl As the result may be lengthy, post the result here and give us the link: paste.ubuntu.com – chili555 May 10 '17 at 21:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.