7

I have been running Xubuntu 16.04 without any errors on just the generic drivers that come installed by default. I decided I wanted to play some video games so I installed the AMDGPU-PRO drivers by following the directions here: http://support.amd.com/en-us/kb-articles/Pages/AMDGPU-PRO-Install.aspx

cd /tmp
tar -Jxvf amdgpu-pro-17.10-414273.tar.xz
cd amdgpu-pro-17.10-414273
./amdgpu-pro-install -y

now when I boot my computer, I see my motherboard startup screen and can access the bios, but if I try and boot the SSD my install is on, I just get a black screen it doesn't appear to be outputting a video signal. I've tried 3 monitors all with the same result, I am not too worried about getting AMDGPU-PRO drivers to work, just with getting my system bootable again. So my quesiton is how can I boot into a state that I can uninstall the drivers?

I've tried SSHing into my desktop from my laptop, but my desktop isn't responding to that.

For anyone looking into this currently, I never solved for 16.04, but a Radeon R9 390 with AMDGPU-PRO is working great on Ubuntu 18.04

7

Ran into this question while trying to solve the same problem, I solved it just by uninstalling amd driver.

  • Enter ubuntu Recovery mode while booting in.
  • Enable networking and mount file system using the recovery options.
  • Now "Drop to the root shell prompt".
  • Use amdgpu-pro-uninstall command to uninstall.

"exit" and everything should be back to normal.

  • I ended up reinstalling everything so I can't test this, but that definitely looks like what the right course of action would've been except I couldn't boot into grub to access recovery mode – kalenpw May 15 '17 at 18:09
  • Indeed the right approach! Got it removed with this method! – Numan Oct 1 '17 at 15:40
2

I had the same issue it is because of the modification to the initrd file in /boot folder. You can recover by reverting to the old initrd file stored in /boot as initrd.dkms.old. I didn't know how to do that, so I just reinstalled the OS.

Also, the amd install guide said that there is a amdgpu-pro-uninstall script in the extracted folder but there isn't.

Update if you find a way to reverting to the old initrd or another way to fix the problem apart from re-installation.

  • Yeah I ended up just reinstalling and am going to avoid amdgpu drivers a bit longer – kalenpw May 15 '17 at 18:08
  • This worked for me! Saved me hours of work not having to re-install. Thanks :) – Brannon Jul 18 '17 at 5:35
  • 1
    I found the amdgpu-pro-uninstall script was linked as /usr/bin/amdgpu-uninstall into /var/opt/amdgpu-pro-local/ as part of the installation procedure. Their docs have not been updated to describe that departure from their instructions. – dune.rocks Jun 23 '18 at 22:25
1

If you are looking for the amdgpu-pro-uninstall script for newer installs it can probably be found in a different directory (as mentioned in the comments), try

/usr/bin/amdgpu-uninstall
/usr/bin/amdgpu-pro-uninstall
0

It seems that the amdgpu-pro-uninstall sh file is missing at least in my case However in the amdgpu-install.sh file there is an uninstall function called by dryrun

if [[ "${OPTIONS[*]}" =~ "dryrun" ]]; then
    echo PACKAGES: ${PACKAGES[*]}
    amdgpu_pro_uninstall
    return 0
fi

Try /var/opt/amdgpu-pro-local/amdgpu-install --dryrun

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.