21

I ran powertop, and it says that the Realtek audio codec is using 100.0% of the cpu. Is this a problem?

I'm running Ubuntu 11.10 32-bit on Intel® Core™ i7 CPU M 640 @ 2.80GHz × 4 Sony VAIO laptop.

  • It says that it's active 100% of the time, not that it uses 100% of the CPU. ;) I don't see it causing any trouble here. – htorque Dec 29 '11 at 19:44
  • you can enable power saving mode on the audio speaker using powertop – Edward Torvalds Mar 3 '19 at 9:47
9

No, it just means that you have (probably digital) sound output enabled. If you have some sound outputs, such as digital (optical/coaxial) or hdmi you are not using, then you can blacklist their drivers and you might save some battery. They will be listed in lsmod something like, snd_hda_code_realtek and snd_hda_codec_hdmi. By adding these to /etc/modprobe.d/blacklist.conf you can disable them.

  • In case someone finds this question looking for a way to remove the realtek audio from Powertop DO NOT FOLLOW THE ABOVE ANSWER. Blacklisting the drivers will disable all audio from your machine. The only way to fix it is to remove the blacklisting and then doing a hard shutdown with sudo sh -c "echo o > /proc/sysrq-trigger". USE THE ANSWER BELOW THIS ONE – creativiii Sep 23 '18 at 17:48
21

Try changing "Enable Audio codec power management" to good in the Tunables tab for powertop. After doing so, hwC0D0 is no longer listed in powertop for me.

6

I found that muting the microphone input in the mixer solved the problem. I use a Dell XPS17.

  • This mean your microphone was constantly listening? – Dan May 3 '18 at 8:24
0

Muting / disabling stuff with alsamixer helped me get rid of the same problem on macbook air.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.