0

Posting here hoping someone knows how to fix this...

We use a lot of Ubuntu + NVIDIA in our shop, and while usually the procedures outlined in other answers work (such as this great answer) for the class black screens after login, it doesn't work for our new Kaby Lake-based machines.

We are running:

  • Intel Core i7 7700K (Kaby Lake)
  • B250 (Union Point) chipset (ASUS Prime B250-M Plus motherboard)
  • Secure boot disabled in BIOS
  • nomodeset in grub
  • Tried various NVIDIA driver versions.
  • Tried both 16.10 and 17.04
  • Tried with and without intel-microcode
  • Tried installing the latest from ppa:graphics-drivers

We get the classic black screen after logging in once the NVIDIA drivers are installed.

We could not fix it on these machines -- we tried many different offered solution. We moved the hard drive into a 4790K-based machine and it worked immediately, thus there is a real difference with either Kaby Lake, B250 chipset or the 7700K.

  • I'm really not sure that there is a question here - it looks like much more of a statement. – Charles Green May 10 '17 at 2:46
  • If you disable nVidia/PCIE graphics and use CPU graphics, with video connection to motherboard does it work? Then install newest nVidia from ppa, change UEFI settings, and see if nVidia works. Older Asus Z97: askubuntu.com/questions/615896/… – oldfred May 10 '17 at 4:36
  • I amposting in the hopes someone fixes this issue. I reproduced it on two machines with clean installs.It does work out of the box if I do not install the NVIDIA drivers, but unfortunately, I need true GPU acceleration. – bhouston May 11 '17 at 2:29
  • 2
    Possible duplicate of My computer boots to a black screen, what options do I have to fix it? – Anwar May 12 '17 at 11:21
  • 1
    @Anwar, it is not a duplicate, this is about incompatibility between current nvidia drivers and KabyLake CPU or the Union Point chipset. – bhouston May 12 '17 at 14:54
1

We faced a similar problem. The solution was to boot into recovery mode and install Cuda 8 (which includes the nvidia graphics driver) from there. You need some preparation (e.g. download Cuda 8 as *.deb and safe it on a USB drive). By doing so on a freh Ubuntu installation, there was no need to manually set nomodeset or to blacklist stuff. It was all done by the CUDA installation. Worked on 14.04. and 16.04. LTS

I strongly advise not to install the Nvidia driver on Ubunntu via the .run scripts. You need to reinstall the driver after every Kernel update.

0

So I've been fighting with the same problem and finally got it fixes with the second option of this guide: https://gist.github.com/wangruohui/df039f0dc434d6486f5d4d098aa52d07

-----/* TLDR *\-----

Installing Nvidiadriver via .run files:

Remove Previous Installations (Important)

   sudo apt-get purge nvidia

Note this might remove your Cuda installation as well

   sudo apt-get autoremove

Download the Driver via wget, remember to substitute < version> with the version you want:

  cd ~
  wget http://us.download.nvidia.com/XFree86/Linux-x86_64/<version>/NVIDIA-Linux-x86_64-<version>.run

Install Dependencies: As a summary, executing

  sudo apt-get install build-essential gcc-multilib dkms

Create Blacklist for Nouveau Driver

Create a file at /etc/modprobe.d/blacklist-nouveau.conf with the following contents:

  blacklist nouveau
  options nouveau modeset=0

then

  sudo update-initramfs -u

READ CAREFULLY BEFORE PROCEEDING!

Here comes the tricky part which the guide doesn NOT tell you. After turning off you have to press ctrl + alt + F1 to enter a terminal!

Stop lightdm/gdm/kdm

  sudo systemctl stop lightdm

or use gdm or kdm instead of lightdm

Executing the Runfile

  cd ~
  chmod +x NVIDIA-Linux-x86_64-<version>.run
  sudo ./NVIDIA-Linux-x86_64-<version>.run --dkms --no-opengl-files

Hope this helps someone somewhere with something :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.