0

I have ran into a pretty major problem I'm having trouble fixing. Been at it for a few days and I'm just wondering if anyone can point me in a direction of something that might work.

So my situation is this: I first installed ubuntu, then installed windows on another partition next. I had to repair grub in order to get it to work properly and that worked fine. As time went on I realized I needed a bit more space on my Windows partition, so I booted into a LiveUSB and used Gparted to shrink Ubuntu.

This is the output of fdisk -l on my current system so I can better explain the mistake.

Device     Boot     Start       End   Sectors   Size Id Type
/dev/sda1            2048 327841791 327839744 156.3G 83 Linux
/dev/sda2  *    327841792 329338879   1497088   731M  7 HPFS/NTFS/exFAT
/dev/sda3       329338880 608585727 279246848 133.2G  7 HPFS/NTFS/exFAT
/dev/sda4       608587774 625141759  16553986   7.9G  5 Extended
/dev/sda5       608587776 625141759  16553984   7.9G 82 Linux swap / Solaris

Now here is where the problems came. My Linux partition is on /sda1 . and Windows bootloader is on /sda2, and Windows is on /sda3. Since moving free-space afte shrinking can only be moved 1 devices at at a time. I simply shifted it down the line. Put /sda1 70gb-> /sda2 -> sda3.

Well, doing that tottally destroyed my Windows bootloader. I get the following message when I use the grub menu to pick windows:

winload.exe is Missing or Corrupt.

My Xubuntu partition still boots fine, and that's actually what I'm making this post from. I tried to run EasyRT, but I couldn't really get anything to boot.

Any help is GREATLY appreciated!

  • I'm sorry to say that I broke my dual booted windows irreparably by using gparted to change the windows partitions. The painful lesson I learned was to only use windows tools to modify windows partitions. – Organic Marble May 10 '17 at 0:56
  • I'm able to mount the partition on my ubuntu system and access all the files on it, so it's not too big of a deal, since I can get the info off. Question: I can just put everything back on my ubuntu partition, then just boot a windows CD after wiping all the partitions except windows? I just don't want to mess up my ubuntu partition. Guess I should back up again and just re-install everything with the right sizes. – sluginfinite May 10 '17 at 1:46
  • Windows has information in its PBR - partition boot sector that must match partition table on start partition & size. It can easily be fixed by running chkdsk from your Windows repair flash drive on all the NTFS partitions. And sometimes you have to run chkdsk more than once. You may also need other Windows repairs. – oldfred May 10 '17 at 3:31
0

I fixed the issue. It took a bit of trial and error but I will try to detail the steps I took to fix it.

First things first, I used a windows 10 installation disk. I booted into it, instead of installing I went to troubleshoot > advanced settings > command prompt. I issued the following commands:

bootrec /fixMbr
bootrec /fixboot

I then restarted and found that it didn't load Grub and that it went straght to the winload.exe missing screen. I'm sure this step was unneccesary and I could have just continued the following commands:

bootrec /scanos
bootrec /rebuildbcd

After those commands were issued and I reset, I was able to boot into my Windows partition successfully, and could see that I successfully raised the size of the partition from 70gb to 140gb. The next step is to re-install grub from a Ubuntu LiveUSB.

I used Boot-Repair to fix grub. I used the graphical method and all the default options and it worked flawlessly.

gksudo Boot-Repair

Hope that helps anybody with a similar issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.