0

I'm on Ubuntu 16.04 GNOME, and for a few weeks, whenever I'm running the Software Updater, I'm getting the Not all updates can be installed error:

Partial upgrade

After going for the Partial Upgrade option, pending software updates itself (if any), else I get the The software on this computer is up to date message. Whereas the Continue option gives following message:

Broken software index

Running these commands:

sudo apt install -f
sudo dpkg --configure -a
sudo apt dist-upgrade

Aren't showing any problem, yet this message pops up every time. I even tried the Synaptic Package Manager and tried to fix broken packages, but nothing happened. How to fix this problem?

[EDIT] Here's the output of sudo apt-get update && sudo apt-get upgrade:

Ign:1 http://dl.google.com/linux/chrome/deb stable InRelease    
Hit:2 http://dl.google.com/linux/chrome/deb stable Release
Hit:3 http://ppa.launchpad.net/numix/ppa/ubuntu xenial InRelease    
Get:4 http://security.ubuntu.com/ubuntu xenial-security InRelease 
Hit:6 http://archive.canonical.com/ubuntu xenial InRelease [102 kB]    
Hit:7 http://ppa.launchpad.net/papirus/papirus/ubuntu xenial 
Hit:8 http://ppa.launchpad.net/snwh/pulp/ubuntu xenial InRelease InRelease 
Hit:9 http://ppa.launchpad.net/tista/adapta/ubuntu xenial InRelease    
Hit:10 http://in.archive.ubuntu.com/ubuntu xenial InRelease
Get:11 http://in.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB]
Get:12 http://in.archive.ubuntu.com/ubuntu xenial-backports InRelease [102 kB]
Fetched 306 kB in 32s (9,375 B/s)
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

[EDIT] List of repos:

Canonical Partners
http://ppa.launchpad.net/snwh/pulp/ubuntu
http://ppa.launchpad.net/papirus/papirus/ubuntu
http://ppa.launchpad.net/tista/adapta/ubuntu
http://dl.google.com/linux/chrome/deb/
http://ppa.launchpad.net/numix/ppa/ubuntu
  • Instead of apt, try apt-get, as in sudo apt-get install -f and sudo apt-get update && sudo apt-get upgrade – Charles Green May 10 '17 at 0:41
  • " I even tried the Synaptic Package Manager and tried to fix broken packages, but nothing happened. " Can you expand on what "nothing happened" means? Did Synaptic show broken packages? – Organic Marble May 10 '17 at 1:00
  • @CharlesGreen I tried the apt-get just now, still getting the problem. @OrganicMarble When I go to Edit -> Fix Broken Packages in Synaptic, the status bar shows Successfully fixed dependency problems message instantly. – Adnan May 10 '17 at 19:16
  • When you use sudo apt-get update && sudo apt-get upgrade, can you append the output of this command to your question? – Charles Green May 10 '17 at 19:22
  • @CharlesGreen done. check the edited post. – Adnan May 10 '17 at 19:45
0
  1. Try deactivating the unsupported updates in the Software & Updates window.
  2. Go to the tap, where you can see a list of repos. Look carefully on all checked repositories. Deactivate the repos you don't know and they seems weird to you like unofficial graphic driver repos
| improve this answer | |
  • Already done that, the problem persists. – Adnan May 14 '17 at 22:58
  • Maybe you forgot something. Can you paste your list of repos please. Note: I had the same problem like you and I have fixed it (see my answer) – Valor Naram May 15 '17 at 17:00
  • I hope we find a solution in order to provide help for users, who have the same problem – Valor Naram May 15 '17 at 17:01
  • Added list of repos. Check the question. – Adnan May 16 '17 at 17:29
  • Do you know what do you have done before the problem has occurred? – Valor Naram May 16 '17 at 17:32
0

Software Updater initiated updates began causing those Partial Upgrade dialogs after I enabled the

Developer Options > Pre-release updates (artful-proposed) setting.

Those dialogs stopped after I unchecked Developer Options > Pre-released updates.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.