0

I created a live USB for the lastest Ubuntu DVD image using UNetbootin. The image file is ubuntu-17.04-desktop-amd64.iso with MD5 iso18cc54af55d7ca931bbb8588e8d9c1bd.

Everything works fine, but the persistence feature doesn't seem to work. The system does not remember WLAN passwords or any other thing like Web browser history, bookmarks or keyboard settings. The casper-rw file in the USB root is not mounted (I checked in /proc/mounts and with df -a).

I then created a second partition on the USB drive, formatted it with ext4 and named it casper-rw (I left the casper-rw file on the first partition). This partition gets mounted at boot, but contains no data. The system does not save any data inside it as well, so besides mounting it it seems unused.

What else can I do to enable the persistence feature? How can I enable mounting of the casper-rw file? I don't like to have an extra partition on the USB stick, it's easier to resize/recreate a file than to move around partition boundaries if space runs out sometime in the future.

  • Actually both links are identical, and I got the idea of making an extra partition from this or a similar post already. Renaming/Deleting the casper-rw file from partition1 does not change anything as well ... – hochl May 9 '17 at 15:14
  • See the answer from the above links suggesting using mkusb. That is current, and works. You can add a partition, but how are you going to edit the grub.cfg on the read-only iso9660 filesystem? – ubfan1 May 9 '17 at 16:03
  • I tried using mkusb-nox, but all it does it dd the iso to the USB drive :/ – hochl May 9 '17 at 16:09
  • Have you tried the persistent option of mkusb? It will create a boot partition, (where grub.cfg resides), a read only ISO9660 partition for the OS files, an ext casper-rw partition and a NTFS data partition that can be used by Linux or Windows. You can replace the casper-rw partition with an unnamed FAT32 partition and put casper-rw or home-rw files in it if you prefer a persistent file. – C.S.Cameron May 9 '17 at 17:35
2

Persistent partitions are still not working with syslinux type installs with 17.04, including UNetbootin's .

Mkusb boots using grub2, it has worked for me using persistent partitions with 17.04. With a bit of work the casper-rw partition can be replaced by a casper-rw file.

Using gparted, change the casper-rw partition to FAT32 and leave the label blank. Copy a casper-rw file, (made using UNetbootin), to the partition. Max size for a FAT32 casper-rw file is 4GB.

If you wish you can make multiple persistent files with this method, put each casper-rw file in it's own uniquely named folder on the partition. Then the path to that folder is given in the menuentry in grub.

  • I created the USB stick with mkusb and it works, which is great. The only thing left is the question if it is possible to encrypt the persistent partition. I remember I once had a live USB stick that asked for a password on boot, which was pretty cool. – hochl May 11 '17 at 21:58
  • I don't think I have heard a clear answer to that. It might make a good Ask question, most of what I read says that it is not possible to encrypt casper-rw. If you want an encrypted pen drive, do a Full install, you can select encryption during the install process. – C.S.Cameron May 12 '17 at 16:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.