1

I use circle CI for as our continuous integration solution. I am trying to install mariadb 10.1.20.

And I use this

sudo DEBIAN_FRONTEND=noninteractive aptitude install -y mariadb-server

But it comes to a problem.

Setting up mariadb-server-5.5 (5.5.54-1ubuntu0.14.04.1) ... * Stopping MariaDB database server mysqld ...done. dpkg: error processing package mariadb-server-5.5 (--configure): subprocess installed post-installation script returned error exit status 1 Setting up libdbd-mysql-perl (4.025-1ubuntu0.1) ... Setting up libhtml-template-perl (2.95-1) ... dpkg: dependency problems prevent configuration of mariadb-server: mariadb-server depends on mariadb-server-5.5 (>= 5.5.54-1ubuntu0.14.04.1); however: Package mariadb-server-5.5 is not configured yet.

dpkg: error processing package mariadb-server (--configure): dependency problems - leaving unconfigured Processing triggers for libc-bin (2.19-0ubuntu6.7) ... Processing triggers for ureadahead (0.100.0-16) ... No apport report written because the error message indicates its a followup error from a previous failure. Errors were encountered while processing: mariadb-server-5.5 mariadb-server E: Sub-process /usr/bin/dpkg returned an error code (1) A package failed to install. Trying to recover: Setting up mariadb-server-5.5 (5.5.54-1ubuntu0.14.04.1) ... * Stopping MariaDB database server mysqld ...done. dpkg: error processing package mariadb-server-5.5 (--configure): subprocess installed post-installation script returned error exit status 1 dpkg: dependency problems prevent configuration of mariadb-server: mariadb-server depends on mariadb-server-5.5 (>= 5.5.54-1ubuntu0.14.04.1); however: Package mariadb-server-5.5 is not configured yet.

dpkg: error processing package mariadb-server (--configure): dependency problems - leaving unconfigured Errors were encountered while processing: mariadb-server-5.5 mariadb-server

I don't know even what dpkg is. Could someone help me out ?

  • Looking into the error. It tells me that mariaDB is dependable from the mariadb-server-5.5 ? Is this correct ? – Speedy May 9 '17 at 9:11
  • 1
    Try dpkg --configure -a. If there is a real dependency problem, the command will tell you. – Jos May 9 '17 at 9:43
  • ubuntu@box1533:~$ sudo dpkg --configure -a ubuntu@box1533:~$ I have nothing. This means that I haven't got the dependency problem. Right ? – Speedy May 9 '17 at 12:38
  • Before I can provide an answer, please let us know 1) Which version of CircleCI you are using, 1.0 or 2.0, and 2) if 1.0, which image are you using? Ubuntu 12.04 or Ubuntu 14.04. – FelicianoTech May 9 '17 at 16:51
  • Using CircleCI 1.0. Ubuntu 14.04. – Speedy May 9 '17 at 18:07
1

I have solved it, but know I have different problem.

Firstly in order to solve it, you have to delete all of default mysql from your server using this How do I uninstall MySQL completely?

Then, from the links from MariaDB site just one works and it's Bulgarish. https://downloads.mariadb.org/mariadb/repositories/#mirror=hostag&distro=Ubuntu&distro_release=trusty--ubuntu_trusty

I have come up to other problem. I don't know how to put this prompt window about setting root password away. Anyhow that's other problem then this.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.