2

I’m running Libreoffice writer 5.1.6.2. I need to write letters in French occasionally and before when I was dual booting this computer with Windows 10 and Ubuntu 16.04 had no problems with the spell check in French. Now however I have had no luck.

French has been installed from Language support.

I have downloaded ( 5 times) Language Tool 3.7 and Dictionnaire Française 5.7. I have selected French spelling dictionaries from the language tool drop down and chosen the recommended version.

I have reloaded Librewrite after each change and even rebooted the laptop.

I set my default language to French (France) with the “This document only” box ticked. Also, I change language on the dialogue below the document to French.

I have run the myspell to load the French file.

Yet when I type in French every word is underlined as an error, even the simple words such as “Je suis ...” etc., Setting spell check to auto does the same. However, when I call up spell check with the F7 key I am offered a long string of mixed characters some even Greek letters.

Even changing the paragraph style to French makes no difference. I worked through an excellent and very detailed step by step check on the OO website and all answers were YES right to the end, until I downloaded the check file, which just did not work as suggested.

Obviously I’m making mistakes or missing something, but just what I cannot think. I used the set up with 14.04 on another computer with no problems and as I said on this machine when a dual boot.

My spoken French is quite good, but I need the spell check when writing.

If anyone can help or direct me to what else to try I would be most grateful.

I could not find any other answers here, but maybe I'm missing those also, if so I apologize.

Hal.

  • Thank you Gunnar and Bruni, hunspell seems to be installed, in that all French dialects list when the dpkg is run. Now however Librewriter checks my grammar (also needed) but NOT the spelling. It's as if it cannot find/apply the dictionary. I set my default language to French "This document only" Also my "locale -a" lists French, but I don't know how to start the programme with the LC_CTYPE... command as you suggest. Sorry if I seem untutored, much of this is new to me. – hal_v May 11 '17 at 22:25
  • Thank you again @Gunnar, but that did not solve the problem, I'm wondering if uninstalling Libre Office and reinstalling after a reboot would work. However I am hesitant because to a new user that seems very radical. I am quite mystified as the spell check worked on this machine set up as a dual boot with Win 10 previously. – hal_v May 12 '17 at 22:37
  • I am sorry I have no idea how to do that. I have however checked my paths, and there is no French dictionary listed in Wordbook. I have purge and reinstalled LW with no luck. – hal_v May 13 '17 at 0:20
  • Thank you I am finding out so much more about my system. Yes spell check works in a Guest session with French as Western setting and as paragraph font style – hal_v May 13 '17 at 1:41
  • Let us continue this discussion in chat. – hal_v May 13 '17 at 1:46
2

The conversation in comments and chat proved that the LibreOffice configuration for the user account had been messed up somehow. The solution was to reset it to default by removing the config folder:

rm -rf $HOME/.config/libreoffice
0
sudo apt-get update
sudo apt-get install aspell-fr myspell-fr

kill all libreoffice processes and reopen.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.