5

It's my first time installing Ubuntu. I deleted Windows and installed Ubuntu 17.04 but there is a problem NTFS Partitions are mounted as read only. What do I need to do?

4
  • In gparted either format the NTFS partition again or delete it and recreate. – user680858 May 9 '17 at 12:14
  • I do not want to loss data – AbdallhSamy May 9 '17 at 13:06
  • 1
    You should have mentioned that in your question. Copy the files from your read-only NTFS partition to a (home) directory in Ubuntu. Then do the action I mentioned previously. – user680858 May 9 '17 at 13:13
  • Partition size is 800 GiB – AbdallhSamy May 9 '17 at 13:19
10

Step #1:

First, you should also check your /etc/fstab to assure that the mount for your NTFS partition does so as rw, not ro.

Step #2:

If you still had Windows installed, I'd recommend a different path to fix this problem.

And as always, I'd always recommend good backups.

However, without windows, (and although I wouldn't normally recommend this in a dual-boot environment) you might use ntfsfix.

In terminal...

For more information:

man ntfsfix

To use:

sudo ntfsfix /dev/sdaN # replacing "N" with the correct partition number
4
  • I fixed it by resizing partition using GParted – AbdallhSamy May 9 '17 at 22:14
  • @AbdallhSamy with no backup, that was a dangerous thing to do... and... it should have had nothing to do with the error you were having. – heynnema May 9 '17 at 22:18
  • I'm facing the same problem, I tried above command and it works successfully so I got the privilege to create a folder but when I'm trying to copy files on that partition it says read only!! What should I do? – Jay Patel Dec 12 '17 at 7:25
  • ntfsfix -d worked for me – elig May 30 '19 at 13:46
1

This will solve your problem

sudo apt-get install ntfs-3g

You should unmount your drive, and mount again after that you have installed the ntsf-3g. Ti will solve this lack.

1

I fixed this using heynnema solution and adding

umask=000

in mounting options.

About umask: umask of 000 will make newly created directories readable, writable and descendible for everyone (the permissions will be 777). Such a umask is highly insecure and you should never set the umask to 000... You can see more about it here

As WinEunuuchs2Unix said, typically umask it's set to 022 for 755 access. Also there is fmask and dmask for setting files and directories separately.

4
  • Can you explain what 000 represent? – WinEunuuchs2Unix May 22 '18 at 13:10
  • ... umask of 000 will make newly created directories readable, writable and descendible for everyone (the permissions will be 777). Such a umask is highly insecure and you should never set the umask to 000... You can see more about it here – NewK May 22 '18 at 23:57
  • Thank you. I meant to update your answer with the information as a means of improving it. It's a common request you'll see through out Ask Ubuntu. Welcome to the club :) BTW typically it's set to 022 for 755 access. Also there is fmask and dmask for setting files and directories separately. – WinEunuuchs2Unix May 23 '18 at 0:16
  • Updated response. Thanks for the warm welcome :) – NewK May 23 '18 at 11:28
0

I don't know whether you've got the solution. But, here is what I do when i got same problem on my dual boot PC.

If you are using dual boot with Windows and Linux it is better to boot into Windows and do the disk check using Windows' disk check utility. That will do the trick of resolving the Read only file system error in Linux.

Actually thanks to @spinne, because sudo apt-get install ntfs-3g when I try to resolve with ntfs-3g it shows the cause of the problem. Then I reboot to Windows and did disk check for problem drive and fixed the file system error.

0

A check with the Windows disk utility (chkdsk <drive_letter>: /r from an elevated cmd; taken from https://neosmart.net/wiki/chkdsk/) worked in my case, even though no errors were found. Adding the rw mount option with 'disks' from ubuntu didn't work.

This might be the preferred solution when acting on a partition that is shared in a dual boot. In my case, this is a dual boot with ubuntu 20 LTS and a roll-out version from windows 10.

0

If you're dual-booting with Win10, remember that, if you just Shut Down Win10, it is actually doing something akin to hibernating, which leaves its NTFS partitions read-only for your Ubuntu (etc.) installation.

You can solve this by always Restarting whenever you quit Win10, even if it's just back to your Linux login screen and then you shut down from there. When you next log in to Linux, your Win10 partitions with be Read-Write.

1
  • Let's just ignore that OP clarified in their question that they have deleted Windows already, and focus nevertheless on your suggestion assuming someone reads it who still has Windows installed with dual boot. I recall reading several times that people suggest disabling Window's "fast boot" feature (akin to hibernating). Wouldn't disabling fast boot then have a positive impact on interacting with the NTFS partitions, and make the restart-trick unnecessary? – Levente Mar 14 at 2:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.