1

Drag-and-drop is not working under various contexts in 16.04 LTS on my machine. When I start dragging a file, "hand" icon appears, but then when I hover over another window,and release, nothing happens. I am pretty sure the focus does not change to the new window. I tried starting to drag a file, and then hitting alt-tab until the focus is in the Nautilus window I want to drop into, but that did not work either.

Apparently this issue was fixed before in V 11, 12, 13.10, however it had been working previously when I used 14.04 LTS- 16.04 LTS. I reinstalled 16.04LTS after a hard drive issue, same hardware, and now it seems drag-and-drop isn't working. I am using Gnome, not Unity, which apparently had a bug that caused this issue. Not running VMWARE, which also had a bug that caused this issue.

I've verified I cannot drag and drop between Nautilus windows, Nautilus to Gmail attachment, and Nautilus image file to Libreoffice.

This post seems to indicate some settings in Dconf-editor that could fix the issue in earlier releases, however I cannot find those settings (open-folder-on-dnd-hover) in my dconf-editor.

Not sure what might affect this. I am running with two graphics cards, but the issue seemed to be there when I only had one card. I can post deets of the cards if anyone thinks it is relevant.

0

I noticed that I has less problems on the third monitor (there were programs that would not run at all on the first two monitors). The monitor that worked best with several programs was running off a Quadro NVS 290. I pulled one of the graphics cards (NVIDiA GTX 460) and the drag-and-drop issue vanished. The one card left is an old Nvidia Quadro NVS 290 running two monitors. I'm currently on Nvidia driver 304.135, which isn't the most current version but proved compatible with these two cards (sort of).

I think the lesson here is to not use two different graphics cards, even from the same manufacturer. It may also be that older graphics cards are more stable, however neither of these cards is very new.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.