0

I recently got my Proliant Microserver Gen8 delivered to me and I'm trying to install Ubuntu Server on it.

The installation process was a success, but when I try to boot from the HDD, it fails and says "Non-system HDD or disk error".

Anyone know why this is happening? I've tried reinstalling twice and also tried Ubuntu desktop to no avail.

I've set the SATA mode to AHCI in system options in bios, since I've read that my RAID controller doesn't support ubuntu.

May also add that after trying to force-boot from HDD, it immediately switches to "Attempting to boot from NIC"..

1

It was quite simple. After some conversation with a HPE employee, I noticed that Ubuntu sometimes labels the HDD's wrong, making my secondary HDD the bootable one. Swapped the position of the HDD's and it all worked out!

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.