3

I have read loads about Linux, kernels and Nvidia over the past few days but I can't solve the issue described here below.

I have installed Ubuntu 16.04 on my Dell 9560 after completely wiping the HD. the kernel is 4.8.0-51-generic from the standard Ubuntu PPA.

The computer has two graphics cards: an Intel HD and a Nvidia GTX 1050.

I have installed the Nvidia driver sudo aptitude install nvidia-375 from the PPA sudo add-apt-repository ppa:graphics-drivers/ppa and in the nvidia-settings - which I use with the accompanying GUI - the section "Nvidia Prime" allows me to choose between the Intel HD and the Nvidia card.

However, when I select my Nvidia card, software like Lightworks performs much worse than when I have selected my Intel HD card whose hardware is nowhere near that of the Nvidia's. Even when I scroll in Firefox the Intel HD seems to do a much better job.

I have tried nvidia-381 but the issue persists. Any ideas if there is a workaround?

Any pros here who would recommend to use some 'grub & modprobe' trick?

  • What performance is the problem? There is a known tearing problem with the laptop Nvidia/Intel combination. – ubfan1 May 8 '17 at 1:14
  • GPU performance is the problem. It's for video editing, not gaming. – johann_ka May 8 '17 at 1:37
  • Did you look at the Nvidia-settings, GPU section, and performance level? Do you have any UEFI settings/BIOS items to select the amount of memory dedicated to the GPU? How much memory do you have (syste./GPU)? – ubfan1 May 8 '17 at 1:49
  • 1
    I suggest you disable the Intel card in the BIOS. – You'reAGitForNotUsingGit May 8 '17 at 1:59
  • The Nvidia-settings show the expected parameters. The BIOS doesn't offer any memory allocation for the GPU. Also, in the BIOS it is not possible to disable the Intel card. My system has 32GB RAM (2400 Mhz) and the Nvidia card has 4 GB RAM. – johann_ka May 8 '17 at 12:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.