I'm trying to install 11.10 alongside Windows 7 from USB, although I've also tried Wubi, but I'm not getting the option to install alongside Windows. I've checked the disk type in windows disk manager and it is basic. Any ideas?

ubuntu@ubuntu:~$ sudo fdisk -l

Disk /dev/sda: 640.1 GB, 640135028736 bytes
255 heads, 63 sectors/track, 77825 cylinders, total 1250263728 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xebfb7460

   Device Boot      Start         End      Blocks   Id  System
/dev/sda1   *        2048      409599      203776    7  HPFS/NTFS/exFAT
/dev/sda2          409600  1210155007   604872704    7  HPFS/NTFS/exFAT
/dev/sda3      1210155008  1241939967    15892480    7  HPFS/NTFS/exFAT
/dev/sda4      1241939968  1250261679     4160856    c  W95 FAT32 (LBA)

Disk /dev/sdb: 8054 MB, 8054636032 bytes
248 heads, 62 sectors/track, 1023 cylinders, total 15731711 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x000cf41e

   Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          62    15729647     7864793    c  W95 FAT32 (LBA)


ubuntu@ubuntu:~$ sudo -parted -l
Matching Defaults entries for ubuntu on this host:

User ubuntu may run the following commands on this host:
  • 1
    If you post the results of "sudo fdisk -l" and "sudo -parted -l", it may help people help you. You can do this from a terminal opened using ctrl+alt+t after you boot from the live USB. – user25656 Dec 29 '11 at 14:54
  • 2
    The information I asked you to post will help determine whether Windows 7 has already used 4 primary partitions, the maximum allowed. – user25656 Dec 29 '11 at 17:06
  • 1
    That should have been "sudo parted -l" not "sudo -parted -l" – tumbleweed Dec 30 '11 at 8:53
  • Sorry about that and, "Thank you tumbleweed!" Doug, please see the correct code provided by tumbleweed. – user25656 Dec 30 '11 at 10:05

I think that you already have 4 primary partitions for Windows 7 (Ubuntu cannot create its partitions because you cannot create more than 4 primary partitions) and so Ubuntu can't show you automatically to install along Windows 7. You have to create manually the space for Ubuntu with GParted and then restart the installation of Ubuntu. Here is a guide on the dual booting Ubuntu-Windows:


If you are unsure when you are partitioning, ecc., please ask a new question here.

| improve this answer | |

Thanks for the help. I ended up deleting two of the Windows partitions in order to install 11.10 64bit version alongside Windows 7. These were labeled recovery and HP tools. I shrunk the main partition using Windows 7 disk manager to share the hard disk equally with Ubuntu. It's all working fine. If I didn't need itunes I would have installed on top of Windows but Banshee and Rhythm Box have never worked with my iphone 4s or ipod nano (another issue I know).

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.