1

I get this error:

sudo dpkg --force-all -i teamviewer_12.0.76279_amd64.deb
[sudo] password for elvis: 
Selecting previously unselected package teamviewer.
(Reading database ... 121496 files and directories currently installed.)
Preparing to unpack teamviewer_12.0.76279_amd64.deb ...
Unpacking teamviewer (12.0.76279) ...
dpkg: teamviewer: dependency problems, but configuring anyway as you requested:
 teamviewer depends on libc6-i386 (>= 2.11); however:
  Package libc6-i386 is not installed.
 teamviewer depends on lib32asound2; however:
  Package lib32asound2 is not installed.
 teamviewer depends on lib32z1; however:
  Package lib32z1 is not installed.
 teamviewer depends on ia32-libs; however:
  Package ia32-libs is not installed.

Setting up teamviewer (12.0.76279) ...
Job for teamviewerd.service failed because the control process exited with error code. See "systemctl status teamviewerd.service" and "journalctl -xe" for details.
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
sudo dpkg --force-all -i teamviewer_12.0.76279_amd64.deb  4.82s user 0.36s system 58% cpu 8.835 total

What can I do to install it?

  • Have you tried installing it using gdebi? sudo apt install gdebi then sudo gdebi teamviewer_12.0.76279_amd64.deb or even apt itself: sudo apt install teamviewer_12.0.76279_amd64.deb – Ravexina May 7 '17 at 21:32
  • This packages is not available in Ubuntu > 12.04. – Ravexina May 7 '17 at 21:41
  • I'm not sure, this package is only available on Ubuntu 16.04: here. – Ravexina May 7 '17 at 21:44
  • This two link might be helpful to you: 1, 2. – Ravexina May 7 '17 at 21:45
  • Please sent it as an answer and describe how did it solve your problem so others will wind it helpful too ;) – Ravexina May 8 '17 at 13:29
6

I have found an answer for this problem here.

There is an official package at teamviewer website and you can get it like this:

wget http://download.teamviewer.com/download/teamviewer_i386.deb

it works for x64 bit ubuntu!!

This package is somehow different and just let's you to install it.

Just download it and run sudo dpkg -i teamviewer_i386.deb

update

this works also for x64 version of ubuntu!

and sometimes the teamviewer wont show the ID number and password, then you need to restart the teamviewer daemon with this command:

sudo teamviewer --daemon restart

and then start the teamviewer again

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.