0

I did a fresh install of 17.04 and having issues trying to connect to my network. I can see all the networks (including mine) but when I try to connect, it just won't let me. Things I have done to try to fix it:

sudo -H gedit /etc/NetworkManager/NetworkManager.conf

then add to the bottom and save:

[device] wifi.scan-rand-mac-address=no

After that I do this command 'sudo service network-manager restart'

I try to connect but it never actually makes the connection. I'm using a Alfa Network USB wireless card (rtl8187 chipset) which has worked fine in Kali linux.

This is the error if I try to delete the WiFi connection to start over:

enter image description here

Never had issues with this wireless card before. Is this just a bug in 17.04 or did I just screw something up?

  • 2
    The correct patch is... on two separate lines... [device] and wifi.scan-rand-mac-address=0 – heynnema May 7 '17 at 19:14
  • @heynnema that's an answer! :P :D – Fabby May 7 '17 at 19:59
2

The correct patch for /etc/NetworkManager/NetworkManager.conf is to have [device] wifi.scan-rand-mac-address=no on two separate lines, and change the "no" to a "0":

[device]
wifi.scan-rand-mac-address=0

and then restart your computer.

  • That seems to have fixed it. The connection is really slow for some unknown reason. Maybe it's the driver for this USB wifi Adapter, I'm not sure. I wouldn't even know where to begin to swap it to see. Maybe I will install 16.04.2 LTS and see how it goes. Not seeing anything in the software updater that might help. Anyways, thanks again – Gbel1 May 8 '17 at 3:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.