0

I tried to change over to gnome desktop with not much success, so I reverted back to Unity desktop. When I did so, a number of issues occurred. 1) Colour of top taskbar has changed 2) Key mappings, in particular, mouse settings were changed. 3) When I go to full display on my external monitor, 1920x1080, the background image/display does not sync to the full display. Eventually I have managed to get a blank display but with no background image.

For 3), tried reinstalling the nvidia drivers, did nothing. Is this a cache issue? At a loss on how revert to my old background.

Hardware platform is a Dell XPS M1330 with a NVIDA GeForce 8400M video card connected via VGA cable to a Dell S2440L monitor. I have to use the monitor given the fact my XPS laptop display is not functioning correctly.

0

could you try to logout to tty (ctrl+alt+F1) switch off your render gdm3 or lightdm if you use Unity I guess it's lightdm, run dpkg reconfigure, reinstall Xorg completely and switch lightdm back on, reboot machine with fresh xorg and go to drivers and install newest for your card supported? should go something like this orderly:

Check your monitor and a laptop connection cable before all, connectivity, cable, if you connect over VGA try HDMI if you have it on your laptop or just change your cable with a 100% working one before you go further. Of course you not gonna destroy system by this, it only gets better how ever you look and set-up your drivers, xorg server conf, lightdm or gdm3 Backup xorg.conf if you prefer by: sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.backup then do the fast cleanup orderly:

  1. go to tty (ctrl+alt+F1) -> type username & pwd
  2. switch lightdm off/disable it for a moment systemctl disable lightdm.service or just systemctl disable lightdm
  3. then uninstall xorg, lightdm, plymouth completely sudo apt-get purge --auto-remove xorg xserver-* lightdm plymouth then remove xorg manualy sudo rm -rf /etc/X11/xorg reinstall all back by: sudo apt-get install --reinstall xserver-xorg plymouth lightdm then sudo dpkg-reconfigure xserver-xorg and sudo dpkg-reconfigure lightdm choose lightdm as Display manager, reboot, update system, update nvidia driver.

Let me know if you stuck, will be here few more hrs :)

  • Thank you for your suggestions for a potential solution. However, given my environment of my setup, namely, requiring an external monitor given that my xps13 screen is not fully functional, I'm looking to see if I can accomplish the tasks you suggested. My previous attempt to introduce gnome required me to utilize grub, which was difficult when one is using a partial screen to type. – David M May 8 '17 at 20:28
  • Did you try to chose another startup display parameters in bios? See if there is an option to set your VGA as a primary display adapter so you can utilize it? – Miki May 9 '17 at 17:24
  • I've managed to resolve 2 of the 3 issues, I initially outlined. However, the display issue is an ongoing problem. When I logged into another unity account, the display was set correctly. When I logged into my account on Gnome, managed to change the display. It appears to be a localised issue with my Unity display background. I don't think it's the bios, given the specifics of the situation. I appreciate your comments and potential solutions. – David M May 10 '17 at 22:02
  • Issue is the lightdm display manager. Able to view display image with gdm3 manager. Since I've nearly set Gnome environment will drop Unity interface. Thank u for your assistance on this issue. – David M May 13 '17 at 18:42
  • I had similar issues with lightdm using Unity environment, just purge it, install gnome + gdm3 or if you like faster and resource-wise lighter combination XFCE+Lightdm works perfect. – Miki May 14 '17 at 19:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.