2

How to Install latest umbrello version under Ubuntu 16.04? I have 2.18 (15.12) in Ubuntu 16.04/Mint 18. Build from sources or some PPA available?

I see Launchpad contains only 2.21 (16.12) version but for newer Ubuntu version. However latest version is 2.22 (17.04)

Here http://archive.neon.kde.org/user/pool/main/u/umbrello/ we have the latest but it requires libqt5core5a (>= 5.7.1+dfsg). Any ideas? Build custom deb package: I know how to build src.rpm - how to do the same in Ubuntu?

Thanks!

3
  • @Alban, anyway: at least 2.21 and 2.22 when it will be released. – Aleksey Kontsevich May 7 '17 at 14:46
  • Why do you mention "Ubuntu 16.04/Mint 18"? – DK Bose May 7 '17 at 15:50
  • @DKBose, why not? :) I have it installed and umbrello version is a little bit old in it. Answer below. – Aleksey Kontsevich May 7 '17 at 19:13
1
  1. Make build directory, cd into it
  2. Download package source codes:

    dget http://archive.neon.kde.org/user/pool/main/u/umbrello/umbrello_17.04.1-0neon+16.04+build22.dsc
    
  3. Unpack them:

    dpkg-source -x umbrello_17.04.1-0neon+16.04+build22.dsc
    
  4. Cd source directory:

    cd umbrello_17.04.1
    
  5. Run (optional: if You want to change package changelog) and edit changelog:

    dch -i
    
  6. Build the package:

    dpkg-buildpackage -rfakeroot
    

    of if in case of any error:

    sudo dpkg-buildpackage
    

Note. For successful build change string usr/share/metainfo to usr/share/appdata in umbrello_17.04.1/debian/umbrello.install file.

  1. In case of error install missed dependencies, in my case it was:

    sudo apt-get install kdoctools-dev kinit-dev kio-dev libboost-dev \
    libkf5archive-dev libkf5auth-dev libkf5completion-dev libkf5config-dev \
    libkf5coreaddons-dev libkf5guiaddons-dev libkf5i18n-dev libkf5iconthemes-dev \
    libkf5parts-dev libkf5service-dev libkf5texteditor-dev \
    libkf5widgetsaddons-dev libkf5windowsystem-dev libkf5xmlgui-dev \
    libqt5svg5-dev libqt5webkit5-dev libxml2-dev libxslt1-dev pkg-kde-tools qtbase5-dev
    
  2. Build the package again:

    dpkg-buildpackage -rfakeroot
    
  3. Install result package from build directory:

    sudo dpkg -i umbrello_17.04.1-0neon+16.04+build22_amd64.deb
    
5
  • Compile most of the time works +1 ;) – Ravexina May 7 '17 at 19:20
  • I unstable however :) Will try 2.21 as well :) – Aleksey Kontsevich May 7 '17 at 19:35
  • If it's umbrello that is unstable I guess it's just the way it is. back in the days when I was working with it at 14.04 a lot of times I experience crashs, etc. – Ravexina May 7 '17 at 19:39
  • @Ravexina, 2.18 worked fine without any crash, will try 2.21 however. – Aleksey Kontsevich May 7 '17 at 21:13
  • @Ravexina, latest version 2.22 released on 12 of May from here archive.neon.kde.org/user/pool/main/u/umbrello works stable for me. – Aleksey Kontsevich May 14 '17 at 15:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.