4

I've upgraded Ubuntu 16.04 with Gnome Flashback to 16.10 and then to 17.04.

After that, switching keyboard layout was set to Alt+Shift, but didn't work. What works is the default Super + Space.

When I want to change in the new UI for keyboard shortcuts, I can't - it doesn't register this shortcut. It seems the shortcuts need to contain some character.

I have tried this solution but it doesn't work either. As a stopgap I am using ['<Shift><Alt>X'].

PS: I wonder why do things that work need to be constantly changed. Does every new version need a new way of configuring the system? And why Alt+Shift, which worked on every system I have ever seen since Windows 3.11 in 90's, need to change now? ...

  • Are you using 17.04 or 17.10? Is a bit confusing to me – Lucio May 7 '17 at 2:46
  • 17.04 of course :) Typo fixed, thanks – Ondra Žižka May 7 '17 at 3:08
  • There was a discussion recently about <Alt>+<Shift> on GNOME Flashback. You may want to study the thread, e.g. this message posted by a Flashback developer. – Gunnar Hjalmarsson May 7 '17 at 6:03
  • @GunnarHjalmarsson thanks, but it basically says it works, while it does not, as I wrote above. – Ondra Žižka May 15 '17 at 4:34
  • I have same problem, can't set Caps Lock as a switch combination – demon101 Jun 23 '17 at 13:38
2

Start Gnome Tweak tool

Typing -> Switching to another layout -> Alt+Shift (or CapsLock, ...)

  • very odd place to find this setting – pcnate May 22 '18 at 19:35
  • @pcnate yes. that's why I wrote the answer – demon101 May 22 '18 at 19:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.