I am trying install 16.04 LTS on an Asus M32CD desktop machine. See specs below.

3.3 GHz Intel Core i5 8GB DDR4 2133MHz 120GB SSD (but have also tried with 1TB HDD)

I am installing from a USB drive. I successfully and error free reach the installation phase where files are being copied and loaded etc. Towards the end I receive an error that the installation has crashed. A separate window appears stating no disc space is available. See picture below.

Installation Error

I have tried different ISOs, tried installing from a CD and USB. I disabled UEFI and secure boot options in the bios as per some other threads I found.

How can I fix it?

  • It looks like the problem may be that the system has not detected the physical disk size. Try running lsblk. This will print the amount of physical disk space your drive has. From there you can try to grow your partition to consume the disk, using this answer. – Camp bell May 6 '17 at 15:50
  • 3
    I can see your partition hosting the / directory is almost full. In particular, if I am not mistaken, /var is eating almost all the available space. Could you please check why it's so full during installation? Anyway, I agree with @heynnema, 5GB could be too small for a complete system. Would you please report about the partition table you defined? – EnzoR May 6 '17 at 16:03

You haven't created a large enough partition to hold a Ubuntu installation. Some might say that you need a minimum of 20G. Probably 30-60G is better for larger installations. It all depends on how/where you're going to configure /home.

DiskSpace Comunity Help


So it turns out my original hunch was correct but I was executing incorrectly. This thread Asus M32CD-B09 cannot install

stated to add i915.preliminary_hw_support=1 pci=nomsi to the grub. In typical Linux forum fashion (and I do not mean to offend) the poster took for granted that everyone knows what a grub is, how to access it, and where to add the change. Digging through other forums I discovered that the lines needed to be added to the end of the Linux section one space after the commands already populated.

This change made the installer properly partition everything.

For anyone having the same issue I was having you access the grub settings by hitting "e" on the initial installation screen.

Thanks for your help everyone.

  • In future, you don't need to dig through loads of forums; search here and, if you can't find it, ask. – wizzwizz4 May 6 '17 at 19:34

Make sure that when you select the partition where you installed, you are selecting the hard drive, you may be selecting the same usb memory and you do not realize

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.