I am using Chromium browser in Ubuntu 14.04 and whenever I visit localhost:8000 or my browser, it redirects to searchguide.level3.com.

When I try to access localhost through the command-line using curl or with Firefox, it works fine. Only Chromium misbehaves as described.

How can I fix this?

  • Does Chromium also redirect you if you start it with a temporary profile (right-click on its launcher icon)? If it happens only on Chromium, I would suspect a malicious browser add-on or something like that...
    – Byte Commander
    May 6, 2017 at 15:26
  • i tried it with a temporary profile and there is no redirects.
    – Ali Faki
    May 6, 2017 at 15:30

2 Answers 2


As a quick DuckDuckGo Search for "searchguide.level3.com" reveals, this is a malicious site and there is lots of malware out there that makes your browser or system redirect web requests to their site.

As you say this redirection does not happen with other browsers or a temporary Chromium profile, my guess is that only your normal Chromium profile got infected. Maybe you find some suspicious add-ons in the chrome://extensions/ Extensions tab, but it's also possible that the infection is hiding itself and sitting somewhere deeper.

Therefore I would personally recommend to nuke all your user's Chromium profile and settings and let it recreate them the next time you start it. Maybe you want to export your bookmarks and write down your stored passwords somewhere before that.

To delete all your user's Chromium profile and settings, exit all Chromium processes and then remove these two directories:

  • /home/USERNAME/.cache/chromium
  • /home/USERNAME/.config/chromium

Additionally, as just deleting the user profile has not worked on the first attempt, you can purge the whole chromium-browser package and clean all its global configuration as well, and reinstall it again afterwards. To do this, run:

sudo apt purge chromium-browser
sudo apt install chromium-browser

Next time be more cautious when you download stuff or visit shady links.

  • still not working after deleting the two directories.
    – Ali Faki
    May 6, 2017 at 17:11
  • Maybe you have to purge and reinstall Chromium additionally to nuking the profile again: sudo apt purge chromium-browser ; sudo apt install chromium-browser ; rm -rf ~/.cache/chromium ; rm -rf ~/.config/chromium. And make sure that no Chromium instance is running any more while you do this.
    – Byte Commander
    May 6, 2017 at 17:16
  • thank you very much! worked flawlessly after reinstallation. please edit your answer to accept it.
    – Ali Faki
    May 8, 2017 at 12:22
  • @AliFaki Great that it worked finally. I included purging and reinstalling the package into my answer now.
    – Byte Commander
    May 8, 2017 at 14:40

To fix the problem, simply search for a good DNS server and use that instead. Google’s free DNS server works for me.

sudo vim /etc/resolvconf/resolv.conf.d/base

Then put your nameserver list in like so:


Finally update resolvconf:

sudo resolvconf -u

Credits: http://subharanjan.com/get-rid-searchguide-level3-com-hack-solved/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.